Alfa Romeo Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1 (Edited)
I have this rattle diesellike sound on low revs and only when applying throttle. The rattle stops immediately as I release throttle or if I keep the revs steady on one spot. It is only there when rpm are rising. When the sound stops, its not calming down and then disapears, its more like on off mode. And is there from idle to 2500 rpm, maybe more but I cant hear it later.. You can hear it at best from idle to 1300rpm. It is a rare 75 turbo but engine internals are same or similar to all alfa nord engines. The sound is there also if I disconnect spark plugs cables one by one. No difference. Also I have checked valve train and remove the cams and lifters and all looks fine there. Valve lash is on specs. Oil pressure is fine. The things gets little better when engine is hot. What could be in these engines that cause that kind of rattle that goes away like on-off as soon I release throttle?

 

·
Super Moderator
Joined
·
11,238 Posts
Turbo rattle?
 

·
Premium Member
Joined
·
21,195 Posts
Piston slap? How many miles on the engine? Did it develop all of sudden or gradually? My first thought before listening was pinging/knocking, but it's not under load, right?
Andrew
 

·
Super Moderator
Joined
·
11,238 Posts
NOT a turbo rattle. Sounds more like initial lean mix on plate opening.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
I was also thinking that can be a piston s ok
Piston slap? How many miles on the engine? Did it develop all of sudden or gradually? My first thought before listening was pinging/knocking, but it's not under load, right?
Andrew
I was thinking also that is a piston slap but when I kill each cylinder one by one there is no difference.
And the knock stop immediately when stop applying throttle even a bit. If it is a piston slap shouldnt knock keep going and after releasing throttle but on slower frequency with tendency to stop? This is more like on off noise controlled with gas pedal.

Its not low milleage engine for sure, 200k or more. I know for sure that I have the noise since rebuild. Before rebuild it have a loud piston slap due to bad piston and exhaust was leaking on manifold so that was just to loud to know if there was this sound before and when it started.

You can see in the video that is there always when I press throttle. It does not matter do I do it in neutral when parked or when driving. Its a little more prominent on uphills.
 
1 - 6 of 6 Posts
Top