Alfa Romeo Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
109 Posts
Discussion Starter #1
I took my 74 GTV out for a drive a few weeks back. It started running funny and misfiring such that it was possibly running on 3 cylinders. When I got back to my garage a found a thick long trail of motor oil! Visibly, couldn't see where the oil was coming from. A week later I started the car and to my surprise, it ran fine! I haven't had a chance to lift the car up, but seems like an oil passage / access point on the motor went wild? Any ideas? Hope to lift the car up this upcoming weekend and look more carefully with a flashlight, but honestly this problem is plain weird... any help appreciated as I'd like to drive this guy to the Coronado Speedfest in San Diego on October 5-6th. Maybe a good mechanic in the Carlsbad area of San Diego could be of help.... thanks! Andre
 

·
Registered
Joined
·
7,166 Posts
What about the seperator and its lines?
 

·
Registered
Joined
·
109 Posts
Discussion Starter #3 (Edited)
oil seperator

I found a thread on the subject, I'll check that out, though I don't remember seeing any oil on the upper parts of the engine compartment...

here's a link to the thread that describes what that is (I confess had to look it up!). I have the same setup with SPICA.
http://www.alfabb.com/bb/forums/showthread.php?t=4722&highlight=oil+seperator

If hypothetically the engine oil blew out from underneath or back of the engine, any other ideas of what might have happened?
 
1 - 3 of 3 Posts
Top