Alfa Romeo Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
Can someone please help ??? I moved to the finger lakes region in upstate NY about 20 months ago from the UK. I need someone that is very proficient w/ these Alfa's & knows how to set them up for fast road & track. I dont want to have to ship her across country, but if needs must !! She does not advance after 4k rpm, in any gear ! She has had a Sperry stage 5 head job and 45mm Webers w/ stebro headers & exhaust. She supposedly has an aluminum flywheel but the cams seem to be bog standard. She has also been equipped w/ msd ignition. Sperry seem to have gone out of business, so no luck there w/ my research. She is stunning bar the performance. Thank you.

Mick
 

·
Premium Member
Joined
·
5,813 Posts
Welcome Mick!

When you say "advance" you are saying that the motor won't rev above 4k RPM, right? Does this also occur when in neutral? Can you tell if it has an aftermarket ignition system? The stock system would be very standard looking dizzy with no additional, outboard electronics and a single small gauge black wire connected to the negative post of the coil (other than the big wires of course).

My guess is that with all that fancy go-fast gear you also have a high performance ignition system that has a rev limiter circuit built in. If so, it should have a brand and model plastered all over it. Google and/or post here to find instructions on how to adjust the limit.

I'm sure others will post local sources for repair in your area. Good luck and post pictures!
 

·
Premium Member
Joined
·
23,250 Posts
You should normally be getting full advance by 2500-3000. Depends on the particular dist, but it's normally in that range. Maybe check the advance mechanism in the dist to make sure it's working.
Andrew
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #4 ·
Thank you Andrew !! I hope that this will help but have a feeling that it's more to do w/ the timing & the cams & 45 Weber's :/
 
1 - 4 of 4 Posts
Top