Alfa Romeo Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
332 Posts
Discussion Starter #1 (Edited)
I have taken apart and cleaned up the wiper mounting and linkage and found three colors... the base layer looked to be black with some red and some white that looked more like overspray than a real coat. The original and previous body color was white. I have no idea where red may have come from. Does anybody know what is correct? Is it black, or is that a primer with body color over?

Thanks
 

·
Registered
Joined
·
332 Posts
Discussion Starter #4
Thanks! That will be going in this weekend.
 

·
Registered
Joined
·
332 Posts
Discussion Starter #6 (Edited)
Thanks Jeff,

I see that yours is a bit different than mine. Mine has a link of fixed length between the motor and left (car's left) wiper (the link is visible in the top of my photo) where yours looks adjustable and similar to the right side. Also, the posts on the two wiper levers (circled) are of unequal length on mine. Only one of mine has a spacer where it looks as if both of yours do.

What I was really looking for is the sequence of washers that are under those snap rings but yours are different than mine. I normally unstack them and take a photo like you did but somehow neglected to. Another question I had was about the fit between the white plastic bushing and the post it slips over. Mine is very loose and made me wonder if another piece was missing but yours looks the same. Mine is covered by a rubber cap but yours is not. Mine had several washers of different size under, and this is what I was looking for. Yours seems not to. My guess is that they are there to keep the rubber seal from getting chewed up by the linkage.

Seeing yours has helped me figure some things out. Thanks for posting!

Joe
 

Attachments

·
Premium Member
Joined
·
268 Posts
Thanks Jeff,

I see that yours is a bit different than mine. Mine has a link of fixed length between the motor and left (car's left) wiper (the link is visible in the top of my photo) where yours looks adjustable and similar to the right side. Also, the posts on the two wiper levers (circled) are of unequal length on mine. Only one of mine has a spacer where it looks as if both of yours do.

What I was really looking for is the sequence of washers that are under those snap rings but yours are different than mine. I normally unstack them and take a photo like you did but somehow neglected to. Another question I had was about the fit between the white plastic bushing and the post it slips over. Mine is very loose and made me wonder if another piece was missing but yours looks the same. Mine is covered by a rubber cap but yours is not. Mine had several washers of different size under, and this is what I was looking for. Yours seems not to. My guess is that they are there to keep the rubber seal from getting chewed up by the linkage.

Seeing yours has helped me figure some things out. Thanks for posting!

Joe
Joe,

I think the second set I have is more similar to yours. Its never been taken apart that I know of. If this is like yours, I could take it apart and document the assembly.

Jeff
 

Attachments

·
Premium Member
Joined
·
95 Posts
fyi the second non adjustable wiper arm is from a US car. you can check the post center to center measurement is about 31 inches. the adjustable arm set center is about 33 inches. The new assemblies that are available are the 33 inch versions and they have to be modified to work. good luck
 

·
Registered
Joined
·
332 Posts
Discussion Starter #9
Thank you

Between all of our photos I'm happy with what I have. I just powered the setup off of a battery and it runs smoothly.

The one issue I have left is that under the joint I have circled above there is a white bushing very similar to those in your photos at the adjustable ends (at your motor and driver side lever). That bushing is VERY loose on mine... the hole in the bushing is probably a full millimeter larger than the stub shaft it fits over. It is round so it is not just wallowed out from wear. I thought perhaps there was supposed to be an additional bushing between the two but there is nothing else there. Are yours anything like that loose?
 
1 - 9 of 9 Posts
Top