Alfa Romeo Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
7,722 Posts
Discussion Starter #1
My silent block at the business end of the linkage needs a change. Anyone have any luck removing the pedal linkage with the engine in the car to do this? I assume with the pedal off and pedal rubber shield at the firewall undone there is room to wiggle it out.
 

·
Super Moderator
Joined
·
10,592 Posts
My silent block at the business end of the linkage needs a change. Anyone have any luck removing the pedal linkage with the engine in the car to do this? I assume with the pedal off and pedal rubber shield at the firewall undone there is room to wiggle it out.
I've never tried it myself, but it seems that I recall reading that it is possible.

Once the linkage is disconnected, what if you pivoted the right side up around where the left side goes through the firewall, until it clears the cylinder head, and then just pull it forward? Probably not that simple! Removing or disconnecting one end of the vacuum hose to the booster might help.
 

·
Premium Member
Joined
·
21,688 Posts
Seems to me I changed that silentbloc in place, though maybe not with the engine installed. Used a big C clamp, or maybe proper sized sockets with a puller/driver bolt.

Andrew
 

·
Registered
Joined
·
7,722 Posts
Discussion Starter #4
Seems to me I changed that silentbloc in place, though maybe not with the engine installed. Used a big C clamp, or maybe proper sized sockets with a puller/driver bolt.

Andrew
Thanks..... but it really needs a coat of paint too. The car is so nice and yet lacking details like this which keeps the fires glowing in winter, here. Uncle
 
1 - 4 of 4 Posts
Top