Alfa Romeo Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
248 Posts
Discussion Starter #1
Howdy all more questions about the 164Q I'm considering.

When I was testdriving it the temp was around the bold bar between 160 and 230 is this the normal running temp? He told me it runns around 220 in city traffic and 195 on hwy does this sound right?

The Moon roof was not working( and was actualy stuckin the 1/4 light position) I press the button to close it and I heard a click like the motor engauging but not moving. Any ideas on a remedy?

The AC need a recharge I believe the the 95's use R134 is this correct?

Thanks

Brian
 

·
Registered
Joined
·
2,414 Posts
Yup, it'll run between the halfway mark and the 3/4 mark most of the time. Even on a very hot day, stop and go traffic with the AC on, my 164LS will run constantly at 220 but not exceed it. I can almost hear the fan run the whole time but I'm too busy trying to stay cool in the car.

Yes, the R134a is not quite the R12. However, if you change the HEPAfilter (which most owners don't know about) in the engine bay, the AC works much better.

I've had some thoughts about replacing the stock condenser in the 164LS with an aftermarket condenser that has more fins/sq.in. and more rows. That and adding a small pusher fan to keep the condenser cooler.... but that's another project for another day.
 

·
Registered
Joined
·
248 Posts
Yes, 220 is about right when stop/go or stopped at traffic light. On freeway moving, 195 or less isn't uncommon.

It does take a little to get used to that reading... :)

The LS AC is certainly on the weak side, on a really hot day 85+ and around town or in mountain road going 2nd-3rd gear, it's still pretty hot inside. On freeway, it's okey.

I was about replacing HEPA filter when I got quoted for $70 a piece, then I backed down... If there's a better source, let me know!! BTW, any instruction about how to get to the filter?

Jess
 
1 - 3 of 3 Posts
Top