Alfa Romeo Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
With engine running, 0 volts at fuel vapor recovery solenoid. If I apply voltage by jumping solenoid it makes a noise, but not a click and I still cannot blow air through it. I was thinking of replacing solenoid but maybe I have another problem, or maybe the solenoid is only powered intermittently.

13v at windshield washer, which I don't really need but my ocd makes me want to get it to work. Pump doesn't run. If I use jumper wires, 13v makes pump run. I tried a different ground and bypassing plug, but still no good. I'm thinking not enough current through switch/wire but my meter only goes up to 5 amps. Any ideas?

Thank you
 

Attachments

·
But Mad North-Northwest
Joined
·
9,887 Posts
I'm assuming this is a 1990? Purge solenoid is triggered by the ECU based on...some specific running conditions, I don't know. It's not always open when the car's running. Don't worry about it.

Yes, I would assume dirty terminals at the switch limiting current to the washer pump.
 

·
Registered
Joined
·
7,382 Posts
13v at windshield washer....Pump doesn't run.
If I use jumper wires, 13v makes pump run
Is your washer bottle under the front of car, drivers side, like on S4 spiders?

so you have voltage at the washer motor...correct?
but the motor won't run?

just how are you measuring that? IGN on and someone pulling the wiper column arm back whilst you measure voltage at the black/white wire connector on the little pump?
OR, are you measuring voltage at steering column stalk?

yet when you power the pump direct it runs....correct?

a thread on getting inside the column stalk (sounds like your problem, depending):
https://www.alfabb.com/bb/forums/spider-105-115-series-1966-1994/146088-combination-switch-clean-lube.html

and a schematic:
 

Attachments

·
Registered
Joined
·
12 Posts
Discussion Starter #4
Yes, it's a 1990. The reason I was checking the solenoid is because of the occasional fuel smell. I thought maybe it is a result of the charcoal canister not being purged. Alfa Parts Exchange is checking if they have one, $25.00. I considered just buying a $10.00 solenoid, but I am concerned of damaging the ECU. Hate to damage the ECU by trying to save $15.00. The washer bottle is under car, left front. I checked voltage there, by someone pulling wiper arm.
Thanks for the great info in your responses.
 

·
Registered
Joined
·
3 Posts
I had a fuel smell in my 1990 and it was the cloth/rubber flex fuel line to the fuel rail. The line is less than 2' long and failed at the hose clamp. That hose clamp is directly over the starter and starter solenoid and the engine bay caught on fire on a re-start. Replace that line as soon as possible.
 

Attachments

·
Premium Member
Joined
·
1,040 Posts
Ouch!!!

That photo brought a tear to my eye and I presume the car was a total loss?

From the looks of extinguisher residue, I can see why CO2 is preferred but when you don’t have a choice...

And 2 1/2 months from the OP till you weighed in? What’s up with that? :)
 

·
Registered
Joined
·
254 Posts
Sure a fire extinguisher is important, BUT even more important is to replace those brittle/old/especially those long; fuel lines!!! A weekend of replacing lines is worth a month of $8K post-fire rebuild!!! Just FYI!!
 
1 - 8 of 8 Posts
Top