Alfa Romeo Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
507 Posts
Discussion Starter #1
So i recently began the perilous task of swapping out the original 86 fuse box for a used, newer model fuse box with the square fuses. I had everything under control (or so i though) until i went to start the car... it would not start.

I was wondering if anybody could take a picture of their '86 spider graduate fuse box so i could see the wires the way they are supposed to be positioned on the relays.

Thanks in advance,
Matt
 

·
Registered
Joined
·
507 Posts
Discussion Starter #3
i had already seen the first picture and the last one is almost identical and all of those connectors are in correctly. The one in the middle is helpful, thank you, but i still need to see a picture of someone's box that has connectors on the right side. I have spent hours looking at the wiring diagram now and still cannot figure it out!
 

·
Administrator
Joined
·
16,407 Posts
Do you have a copy of PapaJam's color coded wire diagrams? They will prove very useful when trying to sort out Alfa wires.

Are all the fuses known good? If they are of uncertain vintage it'd be a good idea to replace them all. No sense saving a few pennies trying to squeeze a bit of life out of old, tired fuses.

What is the battery voltage during cranking? If available voltage drops below the computer's threshold (~ 10.3+V) the engine may sound like it is cranking over OK but it won't get spark & fuel without computer activation.
 

·
Registered
Joined
·
507 Posts
Discussion Starter #5
i do have the diagrams and have been working with them for days now. the fuses are all brand new so thats not the problem.
I think i have finally wired most of it up now, but i have a couple loose wires that i am unsure as to their position: 1 gray wire coming from the gray relay, 1 orange and white wire and the turn signals dont work...any ideas?
 

·
Registered
Joined
·
128 Posts
Thanks for the photos. I was helping "loosemoose17" with the wiring last night... the car starts and everything is fine, with the exception of the turn signals. Any close-up shots of how the flasher is wired, from behind, or help with which terminals go to which wire would be a huge help. Our flasher is an Alfa unit and has terminals labeled with DIN numbers such as: 2, 85, 30, etc.. instead of the: +, -, L, P as is shown on the wiring diagram.
 

·
Registered
Joined
·
3,338 Posts
Here's a closeup from my 86 Veloce. I've got a blade style box sitting in my projects to do pile, hope to get to it once I'm done with the Verde's engine & transaxle...

Can you post some pics from behind of your completed swap?

Kevin
 

Attachments

·
Registered
Joined
·
64 Posts
Thanks for the photos. I was helping "loosemoose17" with the wiring last night... the car starts and everything is fine, with the exception of the turn signals. Any close-up shots of how the flasher is wired, from behind, or help with which terminals go to which wire would be a huge help. Our flasher is an Alfa unit and has terminals labeled with DIN numbers such as: 2, 85, 30, etc.. instead of the: +, -, L, P as is shown on the wiring diagram.
I am having the EXACT same issue. Everything else on my car seems to be working fine, but these turn signals are stumping me! I know it's been a few years, but do you remember what you had to do to get this fixed?
 

·
Administrator
Joined
·
16,407 Posts
Do you have a copy of Papajam's color coded wire diagrams for your model Alfa? You should - they'll make chasing Alfa electrons much easier.

If you don't have them, send him a request via PM. Include your email address and he'll send you some .pdf files. I had an office supply store print them out n 11"X14" paper then plastic laminate them. Makes them perfect for shop use.
 

·
Registered
Joined
·
64 Posts
Thanks Eric. I do and did the exact same thing! Combined with dry erase markers they are invaluable! :)

I had a great conversation on the phone with Jim this morning. Here's hoping I'll get this resolved!
 

·
Registered
Joined
·
1 Posts
Any chance someone can post a pic of the front? I pulled the relays thinking I'd never forget and well... I waited too long and forgot. I think I've got them right from Papajam's wiring diagrams but I'd love visual confirmation. I have an 87 Grad that I swapped in the blade style box. Thanks!
 

·
Premium Member
Joined
·
670 Posts
Handy thread, many of us have these and other issues. Has anybody out there eliminated some of the "unnecessary" items, power windows, rear fog lamps, etc, etc. I would like to strip the wiring down to a minimum and simply recycle some of these things.

thanks
 
1 - 13 of 13 Posts
Top