Alfa Romeo Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi guys

I recently acquired a 1986 Alfa spider Veloce, and I have been combing through the car and electricals.

The two interior foot/floor lights on the driver and passenger side do not work, and I would like to access the area behind the panels to assess the problem.

Can anyone please shed some light on how I can go about accessing the electricals behinds the centre console safely.

Thanks in advance
Vassili
 

·
Administrator
Joined
·
16,765 Posts
Welcome to the BB.

Are you sure the lights are not working? The lens acts as a switch it rocks or tilts to three positions - automatic (on/off with the doors), always on & always on.

There is also a light timer relay in the fuse box. If the timer relay goes kaput the lights don't work in the automatic position (but I think they should still work in the always on position). And the door jamb switches can get corroded causing the automatic function to not work.

To answer your question, hmm, I can't remember... I think the light unit pries out of the console. But it might be better to wait for a reply from someone who knows for sure.
 

·
Premium Member
Joined
·
361 Posts
Yes, they just pull out as a unit. My advice is to cleanup the contacts on the door switch. That was key to getting my pass. side working. I still need to work on the ds one.

Sent from my SM-T710 using Tapatalk
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
Success

Thank you!! I have fixed the lights. It turns out the driver side light worked and the passenger side needed a bulb.
 
1 - 5 of 5 Posts
Top