Alfa Romeo Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 · (Edited)
Car starts. Positive fuel pressure at cold start injector and at all 6 injectors. Cam timing spot-on. Ignition timing spot-on. Plugs new. Plug wires new. Fuel pump new. Iginition switch new.

Tested positive pulse at cold start injector and all 6 injectors. Move air flap and fuel pump runs corrrectly. Fuel pump relay clicks when air flap is moved. Tested for positive grounds between chassis and engine. Coil tests to be good.

Engine fires when cranking with key in "start" posistion. When key is released to "run position" engine dies as if loses fuel pressure or ignition ignitor fails to trigger ignition in "run position".

Fuse in fuse box position #4 must be kept out of car. With #4 fuse installed, starter engages by itself and fuel pump runs constantly with key out of ignition. :eek: Car has battery master kill switch installed in trunk. The moment you turn the switch on to energize car, all of this happens related to the #4 fuse. With #4 fuse out of fuse box, car functions "normally". Starter engages in "start position", car tries to start, but when key released to "run position" car slowly dies after a few seconds.

Is this the sign of a bad ignitor???? Or can you PLEASE help me to direct me to what to test next. Remember this is the car that has been sitting 18+ years without running. I have posted previously on the Forum with other issues and have received excellent help. The car is almost there. I hope someone can help me make this car run properly again. Thank you.

Chuck
(Tearing my thinning hair out! lol!)
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
checking lots of stuff based upon responses.

fuse box is down out of it's swing down position. i've been looking for burns , shorts , rubbed through or any other type of damaged wiring to no avail to date. the only thing i can say with certainty is that the replacement ign switch had no provisions for the illumination.
this weekend is going to be a thorough cleaning and testing of the fuel injection system's componentry. after reading the great article on the car's specific F.I. system , i now want to test each part to be certain exactly where the car is with respect to each item working or not working. i assembled the boxes of pieces from pictures in the shop manual and on line pictures of other cars under hood. i was not the person who disassembled the car so long ago. also i have no other car to compare things either. evrything from firewall forward , electrically and mechanically was disassembled , with nothing tagged , bagged or marked. EVRYTHING! the steering and suspension was assembled, that's it! the car is very close to being a car again with thanks going to those who have read the posts and replied. i'll update after i have some serious investigation done based upon all leads offered.

thank you!
chuck
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top