Alfa Romeo Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
42,000 Miles. My grandfather bought it in 1999-2000. He passed it on to me in 2001. I worked on it through college. I replaced the head gaskets in 2002 or 2003 and the 2nd Gear Synchro in 2003 or 2004. In 2005 it suffered a "plenum pop" while starting it in the cold one morning. It sat for the next 7 years while I joined the Marine Corps and to find a new Mass Airflow Sensor. My brother got it running for me and replaced the brakes and some of the lines. It starts and runs, though since I replaced the ignition switch it doesn't shut down with the key in the off position. I will remedy that as soon as it gets above freezing here. Make me an offer. Located in Northern Virginia.
 

Attachments

·
Registered
Joined
·
20 Posts
Discussion Starter #5
Update on the car

I am still chasing the refusal to shut down but the car is running much smoother thanks to a freshly charged battery. It starts on the first try after only two or three spins of the starter. While I am under the dash I will see what I can do about the temp, tach and speedo. The odo still works, I verified it driving up and down my driveway for 1/10 of a mile. More pictures of the rust spots, because everyone keeps asking, available at the link below.

https://www.dropbox.com/l/V8GCC1xAX8o2Kzm8fxg5Mr
 

·
Registered
Joined
·
164 Posts
relay

it could be the starter relay in the right corner under the hood. That's the cause for the key off engine running issue at most times.
 

·
Registered
Joined
·
14 Posts
GTV6

PhilWagner
Thanks for the response. Im interested in the Alfa and am looking forward to the pictures. My problem is that Im going to have to ship it from N. Virginia to my home in Monterey, California. If the pictures check out, I ask for the location of the car, so that I can get a bid on the shipping and then make an offer.
Brian Morton
 

·
Registered
Joined
·
20 Posts
Discussion Starter #13 (Edited)
Someone wired a constant bypass into the fusebox to compensate for the bad switch. Hardwired an on off switch in place of the bad switch and it starts and shuts down just fine. Car is at the moment, a toggle switch on/off, with a push button start. I will comb through the rest of the fusebox with the diagrams provided by papajam and see if I can get the rest of the gauges working. 40+ pictures available on request. Car IS still available. $1750 OBO.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #14
Someone wired a constant bypass into the fusebox to compensate for the bad switch. Hardwired an on off switch in place of the bad switch and it starts and shuts down just fine. Car is at the moment, a toggle switch on/off, with a push button start. I will comb through the rest of the fusebox with the diagrams provided by papajam and see if I can get the rest of the gauges working. 40+ pictures available on request. Car IS still available. $1750 OBO.
 
1 - 14 of 14 Posts
Top