Alfa Romeo Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
90 Posts
Discussion Starter #1
Hi all. Working on my '74 GTV 2000. It has a Marelliplex electronic ignition, cap and rotor in good shape, new plugs and wires. Spica car. It unfortunately has started to idle a bit rough, and sometimes dies after revs until it is at operating temp. It also has a lag (and sometimes a shudder) between when the throttle is pushed and when the engine revs. Timing looks ok with a light, but I cant really reach the distributor release bolt to adjust it, or I would play with advance... It also runs pretty rich.

All that said, it runs well (I think it could be better, but dont really have any Alfisti friends out here in the Bay Area, so no frame of reference either), and once it is at speed it really purrs.

One other note: I just installed a Centerline Stinger rear exhaust. It does backfire occasionally...

Thoughts?

Thanks!
 

·
Registered
Joined
·
1,798 Posts
Just sticking to basics for now...
What did the old plugs look like... rich, lean, fouled?
Why did you replace the plugs and wires?
When was the last time the fuel filters were replaced? Any indication of low fuel pressure?
How often do you drive your car? If running rich, what does the oil look and smell like? Is it contaminated with gas?
 

·
Registered
Joined
·
1,798 Posts
I would guess the TA is going - all seems to point to a rich condition. I'd suggest installing a dummy TA (do a search for the thread) and checking the .019 gap.
Along that line of thought, has the way the car idle changed in any way as the car warms up? Do you have a fast idle on cold start or does it seem to have lessened from what you’re used to? If so, @gprocket very well could be on the right track.
 

·
Registered
Joined
·
90 Posts
Discussion Starter #5
Thanks all. I’m looking into everyone’s suggestions... good thing is that there is no gas in the oil.

Any suggestions for a wrench that will reach the distributor hold down bolt? I can’t figure out how to get to that...
 

·
Registered
Joined
·
90 Posts
Discussion Starter #7
Advanced the timing a bit (from about 4 to 10) and she is purring now. My tach and Speedo are not calibrated, but that’s for next weekend. :)
 
1 - 7 of 7 Posts
Top