Alfa Romeo Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter #1 (Edited)
This car has been a complete lemon, I have had to fix a lots of problems
2000 166 sportronic 3.0 v6

The latest one is an over heating problem when driving on the motorway at speeds above 100km/h. The temp will rise up to but not above the red line after only a few minutes then start to fall again, it's doesn't seem to happen around town, even on the hottest days with the air con on.

I was thinking it was the thermostat but if so why not do it around town. Has anyone had this or heard of it?
 

·
Registered
Joined
·
273 Posts
Agreed, the water pump is suspect. With a six speed, we would see the temp spike quickly. The water pump was found to have a crack in the plastic impeller, allowing slippage. Water pumps are available with a metal impeller.
 

·
Registered
Joined
·
77 Posts
Discussion Starter #5
Cheers

Thank you, much appreciated. I will order one straight away
 

·
Registered
Joined
·
1,566 Posts
While you are at it, floss the cooling system (radiator and engine) and refill.
I've heard of a Aussie heatwave, that may have tipped the heating prob.
Erik
 

·
Registered
Joined
·
113 Posts
If your going to buy a 166 in Australia make sure the log book is up to speed, however even this doesn't always help. I picked mine up last year and have gone over the whole cooling system with a fine tooth comb. replaced the radiator (was leaking and full of crap) water pump (had an old plastic impellor job still on it) thermostat and pipes for the radiator and heater matrix(that had been done). Best idea is buy the parts from the UK through Alfa Workshops, much cheaper than buying here in Australia and most parts are here within two weeks.
 
1 - 7 of 7 Posts
Top