Alfa Romeo Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
Help......Both my dash "Brake and Stop lights" stay on constantly until the brake pedal is pushed..........than both lights go off at the same time... I do
not know where to start looking for the problem????

Help
Ron
 

·
Registered
Joined
·
2,147 Posts
Could be many things, check stoplight bulb contacts and make sure they are clean first, could be the ARC acting up, they are known to do this on occasion. Goes without saying check all other electircal connections as well. I hear a can of de-oxit can work wonders. Hope that helps,

Jon
 

·
Premium Member
Joined
·
26,815 Posts
Check or pull brake light relay behind false firewall to be sure it is not stuck on or not working, Do you have brake lights stuck on too or no brake lights?
 

·
Registered
Joined
·
2,831 Posts
Another common failure point is the stop lamps control unit mounted on a small frame under the glovebox. Originally white the newest replacements are balck (or dark grey). Usual failure mode is flashing those lights when the brake pedal is pushed though.

Another fault is a break in the pad wear sensor wire which can cause premature signalling of a worn front brake. Usually this is a pedal pushed issue also.
 

·
Registered
Joined
·
3,724 Posts
From my observations pad wear should only be indicated when pedal is pushed. If light comes on when pedal is not pushed it was bulbs. It could still be many things after all these years.
 
1 - 6 of 6 Posts
Top