Alfa Romeo Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3,894 Posts
Discussion Starter #1
Hey fellow Alfisti, I just got a 164 S for a winter car. It is pretty decent, but the heater doesn't work. Being in Maine, this is somewhat of a problem. I can get the fan to run, but it blows cold air. Where is the heater valve? Is there a way I can manually turn it on for the season? I wouldn't mind having the heater permanently set on defrost/dash with the heat on high.
Any thoughts?
Thanks in advance,
Glennco
HMA
 

·
Premium Member
Joined
·
27,304 Posts
There isn't any "heater water valve" unless somebody added a water shut off valve in hose coming off rear of front head.

Check for valve and also check that heater core hoses haven't been bypassed in area/under coolant tank because of a leaking heater core.

Next look straight down from right side (passenger side LHD) wiper arm pivot point between evaporator box and blower motor below windshield and locate temp door lever and cable that goes to temp stepper motor. If lever full forward that is LO not heat position. Raise temp button on a/c panel to HI and see if lever is sucked back towards ****pit.

If not open glove box and remove tire pressure decal square door and see if stepper motors connector hooked up. If stepper motor(s) click probably stripped gears in gear boxes. Rear stepper is temp door lever motor and you can disconnect cable from stepper if you can't pull back lever to get heat and overide stripped gears and hook a wire on cable and pull lever back for heat.

If front stepper won't change air drum to heat and defrost vents you have to just enjoy whatever/wherever air comes out wherever.

Report your findings.
 

·
Registered
Joined
·
3,894 Posts
Discussion Starter #3
Thank you Steve,,
I will try these ideas tomorrow and report the results.
 
1 - 4 of 4 Posts
Top