Alfa Romeo Forums banner

starting

  1. GTV6 problem starting

    Alfetta & GTV6 (1972-1986)
    Hello. I recently changed the spark plug wires, rotor/distributor arm and a valve cover gasket, and after that the car has been unable to start. The spark plugs are wet, so that indicates that the engine must be getting fuel(?). I tested the spark plug wires with some old spark plugs and they...
  2. New Alfa Owner

    Spider - 105 & 115 Series (1966-1994)
    I have been looking for a Alfa Spider for a while, and finally found one, a 1982 US model. It seems to be in good shape, but has some problems. I drove it home and put it in the garage, but it will now not start (I also posted this issue on another thread . .). I have not been able to figure...
  3. Starting issues

    Spider - 105 & 115 Series (1966-1994)
    I have just been confronted with a starting issue on my S3 1988 Spider. It has spent several months having new carbs fitted and was running like a dream, however yesterday on attempting to start I got a couple of spins of the starter but the engine failed to catch. Then on 3rd attempt nothing -...
  4. Diagnose 1972 GTV Problems Starting w/ Video!

    GT (1963-1977)
    All - Thank you for the help on the center console! Hoping the community can help me diagnose problems starting my 1972 GTV w/SPICA. Here's a link to a video which shows you the start procedure I go thru to get it running. Once the car is warm - turns over very easily. but when cold -...
  5. 1991 Automatic Trans starting issues

    Spider - 105 & 115 Series (1966-1994)
    I have a white 1991 automatic spider. I bought the car at the start of the summer and noticed that although the car usually started right up, it occasionally would not. When I turned the key I'd get no response other than lights turning on in the dash. The starter wouldn't turn over. Car seems...
  6. Sweet sounding?

    Spider - 105 & 115 Series (1966-1994)
    Hi everyone! I had been trying to start my newly acquired project spider for the past few days with no luck - just a great deal of starting fluid wasted. After going through pages and pages of threads on Weber carb starting issues and cleaning I took off my DCOE-2s and have been cleaning them...
  7. Electronic Distributor changeover - Smoking distributor, not starting.

    Spider - 105 & 115 Series (1966-1994)
    Bought the centerline electronic distributor ID405 and the bosch blue coil for my 78 Alfa Spider and wired it up right but when I attempted to start there was a clicking/ticking sound coming from distributor and it started smoking. The spark plug wires are correct and the coil is wired correctly...
  8. idle and starting problems

    164 & 168 (1991-1995)
    Hi, Replaced the idle control valve on my 1995 24v and the problem with high idle revs returned within 200 yards and after a 2 mile drive the car was a dog to start; although idled fine on the return run. Am sending the idle control valve back but in the meantime anyone got any ideas? Thanks...
  9. 95 LS hard starting after several hours

    164 & 168 (1991-1995)
    My 95 LS has been exhibiting some odd behavior lately. I live in Florida and recently, the temp has started to cool down. Every morning, my car starts right up on the first try and runs great. i drive to work and park the car by 8:00am. When i go to lunch around 1:00, the car cranks and...
  10. Alfettas not starting

    Alfetta & GTV6 (1972-1986)
    G'day, I recently renewed all the gaskests etc of my Dellorto Carbies, since putting them back on ive been having a bit of trouble getting my alfetta started. (It doesnt even ignite when turned over.) :mad: The engine has ran before, (very rough though). I have checked that the fuel is...
  11. 86' Spider starts but dies

    Spider - 105 & 115 Series (1966-1994)
    I just bought an '86 Spider Veloce (my first Alfa!) and am having a little problem. I live in Chicago, so the vehicle was winter stored in the previous owners garage. When I test drove it, it cranked obth times and started with no problem. I had a hard time with hot starts after I took it home...
  12. Unsolvable running problem on my 86 spider!!!

    Spider - 105 & 115 Series (1966-1994)
    I'll first start out by saying thanks to any one who can help with this problem. I just rebuilt the engine on my 86 grad spider. I have done a few before, so Ive seen a pretty good amount of problems with my spiders. However this one has stumped me. The big problem is with revving and holding...
  13. 1987 Spider Starting Problems

    Spider - 105 & 115 Series (1966-1994)
    My '87 Spider Veloce will not start when engine is cranking. We have 40 lbs fuel on the rail, good spark in all spark plugs, cold start injector works fine, air balance working, 120 psi in cylinders 2, 3, 4 However, 90 psi in cylinder 1. When cranking, there is a back-pressure "pop" of air and...
Top