Alfa Romeo Forums banner
starting problem
1-5 of 6 Results
  1. Engine Repair, Diagnostics & Rebuilding
    Hi all, I've been dealing with this issue for a while, and now I finally have the time and funds to tackle this issue. Background: 1977 Alfetta Sport Sedan with a 1981 Spider motor swap after the original motor blew. After the swap (done by local reputable Alfa specialist) I was driving on a...
  2. Spider - 105 & 115 Series (1966-1994)
    Hello, 1991 is hard to start first time of the day. Trying to turnover, but not catching. Takes several tries, with finally catching when key is turned continuously for way too long. Starter was replaced about a year ago. Just replaced the intank fuel pump. Any thoughts? Thanks, Rande
  3. Engine Repair, Diagnostics & Rebuilding
    Hey Folks, New to the forum and to Alfas. My old man has an 83 Spider and we stumbled upon an 86 barn find! Ive been cleaning and checking things according to the shop manual as well as the guides for the L-Jetronic guide from Greg (many thanks!). My issue with the 86 Spider is an...
  4. Spider - 105 & 115 Series (1966-1994)
    Hi I have a 1974 Spider with Webers. Running perfectly up until this morning, when it suddenly would not start. The starter, which is fairly new, turns the engine over vigorously, and it occasionally fires but simply wont pick up and take off. Before this, running perfectly with no problems at...
  5. Spider - 105 & 115 Series (1966-1994)
    Hello All, Driving my 1989 Spider Qaudrifoglio over the weekend and running great, until I stopped at a freinds house for two or so hours. When tried to start again it would not turn over at all, plenty of cranking power and turn over but no combustion. Has never had this problem. What might...
1-5 of 6 Results
Top