Alfa Romeo Forums banner

starting issues

  1. Would a bad fuel pump relay cause hard starting? Series 4

    Spider - 105 & 115 Series (1966-1994)
    Hello, I'm trying to solve the hard starting issue. It only occurs on the first start of the day. Temperatures are mild, 50's and 60's Fahrenheit. It seems to be not getting fuel to the engine unless I keep pressing the accelerator and have the key turned on continuously for a very long time...
  2. Inconsistent Start / 10 Second Run - 86 Spider

    Engine Repair, Diagnostics & Rebuilding
    Hey Folks, New to the forum and to Alfas. My old man has an 83 Spider and we stumbled upon an 86 barn find! Ive been cleaning and checking things according to the shop manual as well as the guides for the L-Jetronic guide from Greg (many thanks!). My issue with the 86 Spider is an...
  3. Diagnosing Why My Battery Keeps Dying

    Electrical, Chassis & Lighting
    Hey guys, new member here. I have a 1982 Spider Veloce that appears to be having some electrical issues. Something is draining the battery and I have no clue what or how to find it. It used to randomly sometimes not start and I would have to take out the key and retry multiple times and it would...
  4. Slow Start/Airbag Warning Light/Fuel Gauge

    Engine Repair, Diagnostics & Rebuilding
    Hello I just bought my 1995 164 LS and there are three things that I am finding with the car. First, the car has a new starter but is groggy on the start. When starting the RPMs bounce then after 3 or 4 seconds it starts running fine, but a couple times it stalled out with the second start...
  5. recommendations for a shop/tech in ATL

    DSAROC - Deep South Alfa Romeo Owners Club
    but FIRST maybe some Help? to avoid hourly shop rates... what i have and what i have done in the last few months ;) i have a 1985 GTV6 i am having difficulty with. Done a lot of work myself, replaced a few things butit still will not start .(battery/plugs(correct gap)/plug and coil...
  6. New* 69 Spider (*as in newbie)

    Spider - 105 & 115 Series (1966-1994)
    Hey folks, I'm new to vintage autos and somehow started with an Alfa despite the reputations--amazing what a good looking girl will get away with. She's a 1969 1750 Spider. Needs some cosmetics but other than that in great shape. Dharold's technical forum is amazing and I'm planning on diving...
  7. motronic 4.1 ts diffciult starting

    Engine Management
    Hallo everybody, I've transplanted on my 1988 carburetted spider a 75 ts engine with its electronic management (a full photo story on this pages in the next future) Everything works fine except for a quite long cranking before engine fires up. I checked fuel pressure and realized that the fuel...
  8. 1983 Alfa Spider won't start

    Spider - 105 & 115 Series (1966-1994)
    Can anyone help me on this? I have a 1983 Alfa Spider that has fire but no injector pulse. All ground wires are connected that I can find, all fuses good and fuel pump is operational. Funny thing is that it will run off starting fluid but as soon as you quit spraying, it quits running. Thanks...
  9. 88 2.0 Turbo won't idle

    164 & 168 (1991-1995)
    First of all, this is my first post, so, hello to you all. I've had my 164 for about a month now. I've bought it very cheap (1000€) with only one known issue: a leaking pipe in the turbo. I've since ordered a replacement and it's being manufactured right now. Still, I decided to take the...
  10. My 1991 164L's Engine Cranks, but won't fire up!

    164 & 168 (1991-1995)
    Hey everyone, thanks for taking the time to read this. My 164L has not been driven excessively for some time (usually it gets driven twice a month around the block so it keeps the engine running, if not i at least warm it up once a week), since at this time i only have my driver's permit, and...
  11. intermittent rough idle, starting issues

    Spider - 105 & 115 Series (1966-1994)
    87 quad, 60K on the clock, been slowly going over everything since i picked the car up in march. problem 1) intermittent rough idle, seems like i have normal power but the idle is awfully rough, mirror vibrates like crazy, dash rattles etc. if it was always like this i would assume it was...
Top