Alfa Romeo Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-11 of 11 Results
  1. Spider - 105 & 115 Series (1966-1994)
    As you can see, my sipder is visbly slanted to left. Theorerically everything is in place,all rear bushings were renewed amd bolts were tightened under load (car was standing on wheels). When I measure the top point of wheelarches, the left side is 2cm (1in) lower than the right side, both front...
  2. Links to Alfas for sale elsewhere
    This 1974 is up on BaT, ending today. https://bringatrailer.com/listing/1974-alfa-romeo-spider-46/ The restoration has years but not miles on it. Any Bay Area AlfaBB members familiar with the car? Supposedly it was a regular club/show car. Came from the pacific northwest to the SF area in...
  3. Spider - 105 & 115 Series (1966-1994)
    Kinda Like an "AA" meeting I'm Andy and I am a GROSS POLLUTER:oops: Our 81 (with 1979 air box set up by Wes Ingram 20+ years ago) has been idle for about a year and needed a smog test. It failed miserably (see measurements below). Not only were the measurements way out of whack but we have the...
  4. Spider - 105 & 115 Series (1966-1994)
    I took out the seats and now I am slightly unsure about reinstalling. There are two pieces I am not sure what they are for or how to correctly install them. It is the two brackets with holes. Attaching photos one of which from when I removed the seats but doesn’t really help show these in...
  5. Alfa Romeo Club of Canada (ARCC)
    Hey all, I bought the car in early 2021 with the intention of getting lots of use out of it. I had the wheels made for me, put them on and then it sat. My wife and I got more use out of our ATV so I'm going to reinvest in another ATV. Great runner, no rust. The guibo has some cracking so I...
  6. Suspension, Steering, Brakes, Wheels & Tires
    Hi all, I need some help with my brakes. My '83 Spider Veloce lost it's brakes while driving today. The pressure slowly went down until I couldn't brake at all (over the course of ~5 miles or 10 minutes of backroad driving). I puttered into work using my parking brake. The brake pedal regained...
  7. Spider - 105 & 115 Series (1966-1994)
    Ciao! This is my first forum post, but I've been reading and using all of your advice for years! My 1983 Spider Veloce is having really rough idle. Here's the condition: crank and start to ~1300rpm, then idle dips in about 7 seconds to 500rpm (barely running) for 10 seconds, then back up, and...
  8. Spider - 105 & 115 Series (1966-1994)
    Hello! Having cold start problem with my S3 Spider. It takes 4-5 times of trying till it catch and car starts. Suspecting CSI(cold start injector) - removed it, tried to turn ignition on and nothing sprayed. So removed and sent for ultrasound cleaning. These guys said only after 2 hours of...
1-11 of 11 Results
Top