Alfa Romeo Forums banner

sensor

  1. 164 cabin air temperature sensor

    164 & 168 (1991-1995)
    Hi, I've got my 164 roof lining out at the moment and it seems a good time to change the overhead cabin air temperature fan/sensor for the climate control - it has started to sound a bit rattly at times. I think the part number is 60589771 (a Bosch based unit) but these are hard to find new...
  2. lambda sensor from 2.0 to 3.0

    164 & 168 (1991-1995)
    Hi, Have discovered the lambda sensor on my 24v 3.0 1996 164 has a broken body - it is in tight to the cat but wobbles if you grab it and is leaking exhaust gas. Have a good lambda sensor from a 1996 164 twinspark and wondering if it would work as a short-term replacement. Could it be any...
  3. mass air flow sensor

    164 & 168 (1991-1995)
    Hi, Bosch no longer make new MAF sensors for the 164 so can I ask what other owners are doing when theirs get tired/die?
  4. Crankshaft Position Sensor Mounting Block

    Spider - 105 & 115 Series (1966-1994)
    Upon inspection of my recently acquired 83 Spider I noticed the grey wire "flywheel" sensor was missing from the bell housing under the car. And with that so was the aluminum mounting block/bracket. Does anyone know where to find a replacement mounting block? Or has anyone cleverly fashioned...
  5. 1991 Veloce - Temp guage works only when engine off.

    Electrical, Chassis & Lighting
    I have a problem with my engine temperature gauge, or maybe some other related problem like a sensor. When I start and run my car the temperature gauge will remain unchanged at the lowest engine off level, as if it's not working at all. However, when I turn the ignition off after running the...
  6. '86 Spder Veloce Fuel Pump stays on - drains battery

    Spider - 105 & 115 Series (1966-1994)
    This car has been extremely quirky starting a year ago. It would not start after being driven and turned off. Usually no problem starting cold, after overnight. -Julio, my mechanic and I replaced fuel pump relay, but the problem came back after about two weeks. -We swapped the battery and...
  7. ABS Help

    Milano/75 (1985-1993)
    The other day on my way to work the ABS light went on and the pedal went stiff and braking became quite difficult. Came home, read through a bunch of threads regarding what the problem could be and checked the ABS fuse in the engine bay, and it was was fine. The sensors shouldn't be suspect...
Top