Alfa Romeo Forums banner

rough idle

  1. help! no injector pulse on 2 rear cylinders

    Carburetors, Fuel Injection & Air Intake
    hi, i hope one of you can help me. i know nothing about early computerized or foreign cars. the car is a 1986 spider and the rear 2 cylinders have no injector pulse. it runs rough and eventually dies down if i don't give it gas, it has spark across all 4 cylinders although it is weak sometimes...
  2. 2 L rough Idle and low speed

    Spider - 105 & 115 Series (1966-1994)
    Started our 88 spider the other day and after running just fine the day before it now has a very noticeable miss at idle and lower RPM,seems to clear up around 3000 rpm.We checked for vacum leaks,checked the plugs,wires,cap and rotor...and it still is running rough..What am I missing ???????????
  3. Air oil separator issue

    Milano/75 (1985-1993)
    We'll be doing a fair bit of work this wkd on my Milano 2.5. I've noticed quite a bit of oil on the inside of the intake flex hose, likely due to blow by from the air oil separator. We will soak it in carb cleaner this wkd, but I'm wondering if I'd create an air leak by installing an old school...
  4. Tiny Bubbles in the radiator

    Spider - 105 & 115 Series (1966-1994)
    I have been trouble shooting a rough idle and stumbling acceleration on my stock '85. I'm using the excellent online L-Jetronic guide posted here and trying to get through the process methodically. As i was changing some of the vacuum system hoses today, I noticed a slow, steady stream of...
Top