Alfa Romeo Forums banner

power

  1. Help diagnosing/making sense of a strange (charging system?) issue

    Electrical, Chassis & Lighting
    My 1978 Spider has developed a new feature. After starting the car, pressing the gas pedal causes the "generator" light to illuminate on the dash, more brightly as you press the gas pedal more. This did not prevent the car from driving for the final week of last "season". I first decided this...
  2. 155 v6 engine surge and light

    Engine Repair, Diagnostics & Rebuilding
    Hi all, I have a 155 v6 and I have a few issues. The car starts rough, won't idle on the first start but then its all good. The car feels very low on power and after she warms up the engien surges and missfires and then the check light comes on.. Any ideas especially on the power loss the ex...
  3. steering rack gaitor change

    164 & 168 (1991-1995)
    Hi, Tried changing the big steering rack gaitor on my 1995 164, the gaitor with two holes on the outer face and one big one on the inner. The top nut has a hex key fixing inside it. When trying to undo it with just a spanner the whole top of the assembly moved a bit but nothing more. I have...
  4. Lack of Power when accelerating with cold engine

    GT (1963-1977)
    Hi all I'm suffering (no it's rather my Giulia Junior - or both in hte end...) from a strange effect: The exit of my garage is inclined - when I take the car out (idling is fine), it's hard to get it over the slope, once on the road, it runs great. I have the impression, that there's a lack of...
Top