Alfa Romeo Forums banner
oil pressure
1-8 of 8 Results
  1. Spider - 105 & 115 Series (1966-1994)
    Hello - new to posting on BB, though not new to Alfas. I have read several posts on high oil pressure, but am still a little unclear. A mechanical gauge, installed at the top of the oil filter in place of the idiot light sending unit, reads 26 psi at 900 rpm warmed up, and 78 psi at 3000 rpm...
  2. Giulietta & Giulia (1954-65)
    Hi guys I am in the final stages of a '65 Veloce restoration and have just fired up the rebuilt 1600 Veloce engine for the first time. The oil pressure starts at around 60 psi but rapidly drops off to around 10 or worse. I'm talking within the first minute before the oil has a chance to warm...
  3. Engine Repair, Diagnostics & Rebuilding
    Within the past two years I did a full rebuild on the 2.0 in my Alfetta. New everything other than the timing gear bushings in the block and front cover, and the oil pump since they are so hard to come by. Engine runs absolutely great. Upon a cold start it has 75psi of oil pressure. If I rev it...
  4. Spider - 105 & 115 Series (1966-1994)
    I have inherited an '86 Spider Quadrifoglio that was my pop's pride and joy. It has been great going through the vehicle the past couple of weeks. I think it hadn't been for a ride in about six months prior to pop's passing. One issue that has me a bit stumped is a discrepancy between the oil...
  5. 1900, 2000 & 2600 (1950-1968)
    Hi All, I have rebuilt my 2600 and had the oil pump overhauled. In the process I have incurred and oil pressure problem within the pump or more specifically the pressure relief valve. My car is a series 2 with the relief assembly an integral part of the pump. I do not have specifications for the...
  6. Spider - 105 & 115 Series (1966-1994)
    My 81 alfa romeo spider with 30000 original mile seems to have a problem with oil pressure. I believe it is normal for the oil pressure gage to show low pressure when idling. However recently I notice that the oil pressure gage always fluxuates from 57 Lb to zero, even when cruising at 55 mph...
  7. Spider - 105 & 115 Series (1966-1994)
    Hi All, New to the board and Alfas. Picked up a 1986 Graduate in Eugene, OR, running on three cylinders and the compression check showed cyls 1-4 to be at: 50/160/160/160. Is this catastrophic? Any ideas on what could be the cause? out-of-adjustment/stuck intake valve? Add'l info: 50K on...
  8. 1900, 2000 & 2600 (1950-1968)
    So I'm finally the shiny new owner of a 2000 Sprint 1961 Silver, LHD, AR 10205106396 with engine: AR 6396 Pictures coming soon... After many weeks of discussing, searching, and reading these forums - plus fixing up a few odds and ends with the brakes and clutch before buying it, I picked up...
1-8 of 8 Results
Top