Alfa Romeo Forums banner

odometer

  1. 164 odometer 2.0 and 3.0 differences

    164 & 168 (1991-1995)
    Hi, Have posted before about disappearing segments on a 1995 164 3.0 24v. Have today pulled out the console with a view to swapping the ribbon cable/LED itself from a 1995 16v twinspark 164. Both UK spec. Surprise, surprise for an Alfa - there are significant differences, despite the view from...
  2. 164 odometer lcd segments

    164 & 168 (1991-1995)
    Hi, Have this intermittent issue with the odometer on my 1995 164. It occurs more in wet weather so assuming some kind of damp issue but no idea where.
  3. odometer LCD missing segments

    164 & 168 (1991-1995)
    Hi, For the past few years my 1995 24v 164 Super has been missing LCD segments (in horizontal rows) during winter months. They always came back after things warmed up/dried out but this year it hasn't happened. The missing segments came back once, for about a minute, then vanished again...
  4. Speedo/odo not working: '84 Spider Veloce

    Spider - 105 & 115 Series (1966-1994)
    So, finally drove my new acquisition (1984 Spider Veloce) last Saturday and found out that neither the speedometer, nor the odometer are working. I've heard that the later S3 Spiders had electronic speedos, but as mine is the pre-facelift version, am I right in thinking it's mechanical? I'm...
  5. 84' Speedometer AND Odometer Inop

    Spider - 105 & 115 Series (1966-1994)
    Hey y'all. So recently I've had some unprecedented electrical problems. I THINK it's a fuse but I'm not totally sure (since I don't have a multimeter). First off let me preface this by saying that my battery has been flopping around in the trunk. The piece that holds the thing down was...
  6. Trip meter on speedo stops at 99.9 - '88 Graduate

    Spider - 105 & 115 Series (1966-1994)
    Hi - Interesting problem, I've searched and it appears to be unique. Recently (about 500 miles or so ago) my trip meter stops at 99.9, which also stops the odometer from registering actual miles. Because this is a low mileage car I always reset so the delta is minimal, but the error bothers...
Top