Alfa Romeo Forums banner

idle

  1. carburetor problem

    Carburetors, Fuel Injection & Air Intake
    Hi new engine 1750GTV 1968 weber 45dcoe mechanical fuel pump we started engine, set the timing to 30, engine ran fine (idle at 900/1000) and then we realised fuel pump and fuel filter are inversed (order was 1st to the filter then to the pump). We changed the order (1st to the pump then to...
  2. A/C electrics - Wiring loom

    Milano/75 (1985-1993)
    Hello fellow Alfisti! I finally took the decision to install an A/C to my 1.8 IE 75. I have purchased all necessary items that are required (Heater box, compressor, a/c controls etc.) but I'm missing the engine compartment's wiring harness. After studying the relevant electrical diagrams I...
  3. Gtv6 with 164 24v engine idle problem

    Engine Repair, Diagnostics & Rebuilding
    Hi all, I just recently finished with building a 164 24v engine into my gtv6. i bought the engine wihtout hearing it run, and assumed it should be ok.. So the engine starts directly everytime i start it cold and hot, on cold start it will run for about 15 seconds, and than it will swing...
  4. '86 Graduate cold start idle problem

    Engine Repair, Diagnostics & Rebuilding
    '86 Graduate engine runs great when warm and starts fine cold, but won't maintain idle until run for 3-4 minutes. Troubleshooting tips appreciated.
  5. 1988 Alfa Romeo Starting Help

    Spider - 105 & 115 Series (1966-1994)
    I recently bought a 1988 Alfa Romeo Spider Graduate as my first project car! Although I am fairly new with how cars work, I managed to get mine started. My problem is that it has trouble starting if it is not at operating temperature. If it is a cold start, I have to use starter fluid and keep...
  6. Idle and missfire headache.

    Alfetta & GTV6 (1972-1986)
    Hi all, im new on here and wish I knew this existed a long time ago! I recently pulled down our 1985 gtv6 2.5L to put all new gaskets and seals in it as it leaked like crazy. Got it all together good and started fine etc, but once up to temperature, it starts revving up slowly to 1800 then dies...
  7. fast idle, sloppy shifter

    Spider - 105 & 115 Series (1966-1994)
    My 79 spider which I bought recently but have only driven sparingly idles fast for the first 2-3 miles. Is this normal, I do not always need the chock to start the car but it idles fast regardless. It shifts fine no syncros issues but it is sloppy, and ideals on a remedy.
  8. Spica Idle Speed

    Spider - 105 & 115 Series (1966-1994)
    Hi, After a lot of work to get it back to a road worthy condition, my 1980 alfa spider has just a few more quirks, the main being that it is idling below 500 rpm. I was wondering what the appropriate method for increasing this speed would be. Does Spica have an idle adjustment screw? Thank you.
  9. idle and starting problems

    164 & 168 (1991-1995)
    Hi, Replaced the idle control valve on my 1995 24v and the problem with high idle revs returned within 200 yards and after a 2 mile drive the car was a dog to start; although idled fine on the return run. Am sending the idle control valve back but in the meantime anyone got any ideas? Thanks...
  10. Engine idle

    GT (1963-1977)
    I would appreciate any feedback. Recently picked up my car (1971 GTV) from shop after having head done. Going in I explained that the injection system was out of wack - burning rich, not idling right, etc. Upon putting everything back together he adjusted the injection. While it runs much...
  11. 1000RPM idle, a bit high but what is it?

    164 & 168 (1991-1995)
    So, I'm having this ongoing battle with Joe's 164, an '89 V6, manual. When cold the engine idles nicely. When warm the idle speed is around 1000RPM. It idles smoothly and drives smoothly. Unplugging the idle air valve causes a stutter, then increases the idle speed further. I have put several...
  12. Peculiar Idle Problems

    Spider - 105 & 115 Series (1966-1994)
    My 74 Spider (SPICA) does the following: 1. Starts fine. 2. Idles fine warming up. 3. Idles fine sitting while warm before being taken on the road 4. The longer I drive the more the idle will hunt. 5. When the fluctuations get big enough the engine will die. But is restarted easily however the...
  13. 88 2.0 Turbo won't idle

    164 & 168 (1991-1995)
    First of all, this is my first post, so, hello to you all. I've had my 164 for about a month now. I've bought it very cheap (1000€) with only one known issue: a leaking pipe in the turbo. I've since ordered a replacement and it's being manufactured right now. Still, I decided to take the...
  14. Backfire Problems

    Spider - 105 & 115 Series (1966-1994)
    Hi All, I am at my whits end on this 1974 Spider, Model 2000. I have recenlty converted it to dual Solex Carbs with a European style manifold. I will list out everything I have replaced and tried but I cannot get her to run at an idle and can only get her to run with very little power by...
  15. Cut out on idle after loose intake duct

    Spider - 105 & 115 Series (1966-1994)
    The intake duct on my 1993 Spider S4 (Black) recently came loose. It took a day to figure out what it was and tighten up again (it was cutting out in 1st and 2nd gear). Now the engine cuts out on idle, rest is fine. Does the air flow meter need recalibrating or something? Help (noob) 1993...
  16. GTV-6 loping/cammed

    Alfetta & GTV6 (1972-1986)
    Wondering if anyone else has had this problem with their car and what they did to correct it: At idle the car sounds like it is cammed...has a loping sound to it. I am needing to replace the brake booster(will be done this weekend) but don't think the vacuum leak from that could really be the...
  17. Solex Rich just off idle

    Carburetors, Fuel Injection & Air Intake
    Hi all, I have a 75 spider with Solex's was u.s spec but now has been rebuilt with slightly higher lift cams. It seems to be running quite rich from the sound and looking at the plugs. I have fitted a color tune and tried some leaner than spec idle jets. What I am finding is I can adjust a nice...
  18. 1979 spider stalls when accel from idle

    Spider - 105 & 115 Series (1966-1994)
    1979 spider veloce. Starts great. Idles great (~600rpm). Step on gas ... stalls. Will restart (sometimes needs a couple extra seconds). I can tap at the gas pedal a couple times and it gets going. At speed runs like a top. Hot, cold, whatever, it always stalls when you step on the gas while...
  19. 82 AR Spider runs fine for while, exhibits erratic idle then dies

    Spider - 105 & 115 Series (1966-1994)
    I am hoping someone out there has experienced the problem I describe below, and will be able to offer insight as to the cause. First, I have read many posts on cold start and start and die issues. My car, an '82 Spider Veloce always starts immediately and idles fine when just sitting (i.e...
Top