Alfa Romeo Forums banner

fuel flow problem

  1. Intermittent fuel starvation 84 Spider

    Spider - 105 & 115 Series (1966-1994)
    Three years ago I had injectors serviced and renewed rubber, two fuel filters, plugs, coil. This survivor has been running great. This summer I lose fuel on hard acceleration or sometimes in parking lot. Not sure where to start. Maybe open the tank and inspect that nylon pillow fuel filter...
  2. Rehab of 81 Spider fuel system (and more)

    Spider - 105 & 115 Series (1966-1994)
    Hi all, I have been taking photos of things as I work through getting Alfie back on the road. Fuel tank/sending unit/pump rust is the big chore I've found so far. Have not cranked it, getting the fuel system sorted, changing all fluids and filters first. I thought I'd share a link to the...
  3. 1976 spider fuel issues - moved

    Carburetors, Fuel Injection & Air Intake
    Aloha, My father is off island getting cancer treatment and I thought I would try and get his old spider running that's been sitting in his garage for 12 years. Fuel pump does not work with ignition, but does run when wired directly to the battery. I have replaced fuel lines and filters, cleaned...
  4. 87 Spider starts, then dies--HELP!!

    Carburetors, Fuel Injection & Air Intake
    Thanks to all of you for your advice in my previous threads. My 87 Alfa Spider Veloce, which had sat idle for a few years, now runs. I have installed the following: new battery, in-tank fuel pump, main fuel pump, fuel pump relay, main relay, fuel pump fuse, and fuel filter. After installing...
Top