Alfa Romeo Forums banner

engine mounts

  1. '59 Veloce Spider engine mounts

    Engine Repair, Diagnostics & Rebuilding
    I got a basket case, so not sure what mounts should be used. I bought a set from Alfastop specifically for 750F Veloce Spider. They are installed now and I am measuring about 14 degrees engine angle and about 5 degrees on the oil pan angle. I think the angle should be about 10 degrees on the...
  2. Radiator fan rubbing on cowling

    GT (1963-1977)
    My radiator fan rubs on the bottom of the radiator cowling when the car goes over a bump. I can hear it and there are rub marks on the fan and cowling. I replace the front engine mounts recently which fixed the problem for a short time but it has come back again. The rear gear box mount has not...
  3. Knocking sound

    Spider - 105 & 115 Series (1966-1994)
    Hallo, can someone help me? I have a 1978 Spider. When it is on neutral (no gear) and I accelerate him, it is quiet, but when I am on road its starting to knocking on the start of accelerating on all of the gears. So this is a soung that I hear from the passenger side form the motor bay. It...
  4. While I at it

    Spider - 105 & 115 Series (1966-1994)
    While I am at it I recently purchased (actually I traded an '86 Jag XJ-6 project car and a parts car for) an '86 Quadrifoglio. I knew that the rear muffler needed to be replaced and quickly discovered a small hole in the center unit. I decided to go ahead and replace the entire exhaust...
Top