Alfa Romeo Forums banner

electrical

  1. 1984 Spider no spark

    Spider - 105 & 115 Series (1966-1994)
    Ok folks, I have been tinkering with this thing for a couple years on and off. Life being what it is, I've had to step away a couple times. I'm back at it again. At one point I had it running but it has sat for over a year since I've put any effort into getting it running. I've replaced the...
  2. Westchester County NY - Repair Shop?

    Electrical, Chassis & Lighting
    Hello, I am wondering if anyone knows of a repair shop that specializes in Alfa Romeo's? I have a 1978 Alfa Romeo Spider Convertible that I would like to get checked out. Any repair shop in Westchester, Putnam Counties New York or surrounding areas. I look forward to your reply. Thank you...
  3. I think my radiator electrical fans are acting up.

    Alfetta & GTV6 (1972-1986)
    So here is how it goes, I go up to start the car doing a checkup make sure everything is fine etc... I wait until the car gets to temp 175°F degree then the fans start kicking in... Alright I say to myself. Then, I see the little bastards just simply turn off for a moment then they turn for...
  4. Wire color for tailights

    Electrical, Chassis & Lighting
    Hello, Can anyone tell me what color wire coming from the column switch is for the taillights? I am swapping out a S4 column switch, with a S3 version and the headlamps and turn signals work, the taillights do not come on when the headlights come on. Attached is the schematic page. Thanks, Rande
  5. column switch replacement tailights

    Spider - 105 & 115 Series (1966-1994)
    Hello, I am in the process of swapping out a bad 1991 column switch for a previous series model. Also changing the steering wheel. I connected the wires from the old switch (left them in the fuse box and just cut and spliced the new wires in) They all match colorwise. The headlamps and the turn...
  6. Column Switch S4 rebuild

    Spider - 105 & 115 Series (1966-1994)
    Hi, After having my column switch replaced with a used part on my 1991, it is now only working on high beam setting. I have another used part that I purchased from Ebay. Can anybody recommend a shop to rebuild the switch before I have it installed? I want to make certain it will work properly...
  7. Starting issues

    Spider - 105 & 115 Series (1966-1994)
    I have just been confronted with a starting issue on my S3 1988 Spider. It has spent several months having new carbs fitted and was running like a dream, however yesterday on attempting to start I got a couple of spins of the starter but the engine failed to catch. Then on 3rd attempt nothing -...
  8. 1976 Sprint Veloce Parts

    Alfa Romeo Parts For Sale & Wanted
    Hello, I am parting out a 1976 Alfetta Sprint Veloce. 116.15 The car is located in Los Angeles CA. The interior is in pretty good condition, the car being from the Pacific Northwest. The body is rusty however. The transmission/clutch assembly is in good working order. This being an early...
  9. Issues with my Giulia

    Giulia (2017-current)
    Hello All. I have a 2017 Giulia Q4 AWD that I purchased about 6 weeks ago. I love the car and it's beautiful inside and out BUT it is currently at the dealer and has been for 4 days now due to a engine surge issue, timing issue and electrical issue. The dealer point blank told me they have no...
  10. Diagnosing Why My Battery Keeps Dying

    Electrical, Chassis & Lighting
    Hey guys, new member here. I have a 1982 Spider Veloce that appears to be having some electrical issues. Something is draining the battery and I have no clue what or how to find it. It used to randomly sometimes not start and I would have to take out the key and retry multiple times and it would...
  11. '79 Spider turn indicator stays on?

    Electrical, Chassis & Lighting
    Turn indicator on my new '79 Spider stays on all the time, even with the key off. I also notice that if I turn the wheel to the left the stalk moves down and turns on the left signal. So I'm pretty sure the switch needs a bit of work. Switch causing the lamp to stay on? Need to know as it drains...
  12. 88 Spider fuel pump electrical issue

    Spider - 105 & 115 Series (1966-1994)
    Great forum. I'm hoping there is someone out there that can help me get my car running. I bought a 1988 Spider Veloce last November. I drove it 1.5 hours home. I did brakes and suspension work over the winter. In the spring it wouldn't start. There is no power getting to the fuel pump. The fuel...
  13. 77 Spider fuel system, pump not humming?!

    Engine Repair, Diagnostics & Rebuilding
    Started getting my hands into a 77 Spider (SPICA) I found. Had sat for about 15 years. Previous owner was going to restore and then got sick and couldn't. He did get the tank cleaned and coated, lines and filter replaced. However he never got it running well. I started with basic broken things...
  14. Back up lights -stumper

    Spider - 105 & 115 Series (1966-1994)
    Hello All, new the the boards and first time post. I finally got my cherry 87 Spider Veloce back on the road after a 5 year 'time out' in the garage. After a good tune up etc, it's running great except for some electrical gremlins specifically with the reverse (back up lights). Here's how far...
  15. Total electric failure after collision

    Spider - 105 & 115 Series (1966-1994)
    Hi, I had a collision with my spider veloce '86 about two years ago. It took me a while to spare enough cash to have it fixed but it finally happened. I'm based in Vancouver BC and it was also hard to find a good person to work on my car. On friday I went to get my car with a new battery I...
  16. '74 Spider in Electrical Hell!

    Spider - 105 & 115 Series (1966-1994)
    Hi all, Short version: Spider is completely dead. No interior lights, no brake lights, no engine start, etc. Battery good, fuses good, fusebox getting juice. No idea what to do next (other than towing it somewhere). Long version: A month or so ago, when it started raining in Los Angeles...
  17. temp gauge- Is it just me

    Spider - 105 & 115 Series (1966-1994)
    The other posts were the pictures that made me happy, now the question. On my great drive through the canyon I noticed that my temp gauge was moving with my fuel gauge on the curves. It looked like it was being measured by a float. On the hard lefts, it drifted up into the 3rd quadrant and...
  18. Voltmeter drops to 'zero'

    Electrical, Chassis & Lighting
    When I was out driving yesterday, the radio stopped playing and I noticed that the voltmeter had dropped to nothing. A few seconds later, it went back to reading about 12 volts and the radio came back on. It did the same thing a few minutes later and, this time, the meter stayed at 'zero.' I...
  19. 86 spider quadrifoglio brake lights

    Spider - 105 & 115 Series (1966-1994)
    I recently notices that both of brake lights are out. My knowledge of alfas are very limited and I am wondering where I should look to try to solve the problem and how I will know if some is broken. I have not checked the fuses yet but I am wondering if there is anything else that I should...
  20. No spark- fuel pump runs continuously?!

    Spider - 105 & 115 Series (1966-1994)
    i have an 82 Spider with the L-jetronic. got this as a project for me and my son. replaced both fuel pumps, main and fi relay, new ignition switch and been thru the l-jet diagnotistics already and replaced a few things. Car cranks, but cannot get a spark. Coil was wired backwards, but have...
Top