Alfa Romeo Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 5 Results
  1. Milano/75 (1985-1993)
    Hi All, Looking for some trouble shooting tips. Sylvia is a 1989 Verde. It NEVER starts, first crank, when cold. (since I have had this car +8 years) Starts on 3rd or 4th crank. Starting first crank, only when warm / hot. I have checked timing, it is correct. I suspected fuel pressure so I have...
  2. Spider - 105 & 115 Series (1966-1994)
    Hi everyone! I've been a lurker on this BB since I got my first Alfa back in October. It's a red '87 Spider Veloce that I picked up in Maryland and now lives in NY. The car runs well except for a "tough to cold start issue." The car will only cold start if I throttle the gas a little bit...
  3. Spider - 105 & 115 Series (1966-1994)
    I recently bought a 1988 Alfa Romeo Spider Graduate as my first project car! Although I am fairly new with how cars work, I managed to get mine started. My problem is that it has trouble starting if it is not at operating temperature. If it is a cold start, I have to use starter fluid and keep...
  4. Carburetors, Fuel Injection & Air Intake
    Hi Guys; I am having a problem with cold starting. I have a mildly tuned 2l with 1mm oversized valves from centerline and street performance cams from IAP. I was running the stock jets and ventures for a 2l with DCOE32 weber carbs. Initially, I could barely get the car to start at all, and...
  5. Alfa Romeo Parts For Sale & Wanted
    I am in desperate need of a starter and cold start solenoid for an 86 Spider. If anybody has a used one they could part with (or a new one for less than IAP) I would really appreciate it. Either pm me or email me at [email protected] Thanks so much! -MAtt
1-5 of 5 Results
Top