Alfa Romeo Forums banner

brake lights

  1. Wiring Route to Brake Lights

    GT (1963-1977)
    Yesterday, I returned to my car to find a flat battery - a 1975 RHD GTV I traced the problem to the brake lights remaining on dimly when the car is standing. I'm getting a permanent 2 volts on the feed to the lights, 12 volts, if I disconnect the rear lamps. The brake lights work fine when the...
  2. Main brake lights not working, additional 3rd brake light working

    Electrical, Chassis & Lighting
    Hello guys, I have a 1999 146 1.4 T.Spark and just found out that both my main brake lights are not working, while the additional 3rd brake light strangely still does. After I replaced both bulbs, I was unpleasantly surprised to find that the two main brake lights still don't work...
  3. Brakes cause the parking lights to come on

    Electrical, Chassis & Lighting
    Hi all, I'm restoring my '82 Veloce, and lots of electrical issues. Mostly broken wires and corroded connections. One remaining issue: when I apply the brakes, all the parking lights come on, including the dash lights. The service manual I have is for '86-94, so not sure I'm tracing it...
  4. 86 spider quadrifoglio brake lights

    Spider - 105 & 115 Series (1966-1994)
    I recently notices that both of brake lights are out. My knowledge of alfas are very limited and I am wondering where I should look to try to solve the problem and how I will know if some is broken. I have not checked the fuses yet but I am wondering if there is anything else that I should...
Top