Alfa Romeo Forums banner

blinker

  1. Turn signals not working 1982 Spider

    Electrical, Chassis & Lighting
    I have a 1982 Spider all four turn signals aren't working. I replaced the fuse, flasher and sprayed contact cleaner in the back of the fuse box and in the turn signal switch in the steering column. Any thoughts? Thank you, Joe
  2. 164LS turn signal issue - won't turn off

    Electrical, Chassis & Lighting
    Hi - any thoughts on how to troubleshoot turn signal issue. The left turn signal stays on (blinks normally) when in the off position and continues to blink even with ignition off. If I move turn signal lever to "on" for right turn signal, both signals blink. Emergency blinkers also work...
  3. any use of electric starts the lights blinking

    Spider - 105 & 115 Series (1966-1994)
    Hi and thanks in advance! My 1990 Spider Veloce was broken into a few weeks ago. Since then any time I initiate any use of power (opening a door, touching the brake) the flashers go off --including the dash lights --for about 20-25 blinks. If I don't do anything else it all shuts off so it's...
  4. Rear indicator light not working on Alfa 147

    Electrical, Chassis & Lighting
    The passenger side (LHD model) rear indicator/yellow blinker light does not work. I had the whole cluster out yesterday afternoon and swapped the bulbs and holder with the driver's side to no avail (it worked on the driver's side). I even got the multimeter out on it and although it read a...
Top