'69 GTV brake junction? - Page 2 - Alfa Romeo Bulletin Board & Forums
Reply
 
LinkBack Thread Tools Display Modes
post #16 of 17 (permalink) Old 09-13-2012, 01:42 PM Thread Starter
Registered User
 
Join Date: Nov 2006
Location: NH, Usa
Posts: 197
Brakes smakes.... who uses the brakes? They only slow you down...


So yeah, working on getting a second hand junction.
UngaWunga is offline  
Sponsored Links
Advertisement
 
post #17 of 17 (permalink) Old 09-13-2012, 03:47 PM
Registered User
 
flivesay's Avatar
 
Join Date: Dec 2006
Location: huntsville, alabama
Posts: 1,814
I'd be surprised if it's not harder to find one than you think.

Take it all the way off and inspect it. You should be able to tell if the threads are mangled. Maybe it's a bad lead in thread that's repairable. You can also tell if someone forced the wrong size fitting all the way up. If so, I'd treat it as junk

Frank Livesay Huntsville, AL
Green Alfa - 68 Canadian 1750 Spider Veloce (driver)
White Alfa - 68 Euro 1750 GTV (needs a refresh)

Last edited by flivesay; 09-13-2012 at 03:58 PM.
flivesay is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome