Insecure Login - Alfa Romeo Bulletin Board & Forums
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 12-19-2017, 10:54 AM Thread Starter
Registered User
 
Join Date: Mar 2007
Location: San Antonio, Texas
Posts: 4,028
Insecure Login

Today when I tried to long in, Firefox warned me that the login was not secure. This is problematical since the bb was previously hacked. Has the login sequence been compromised? Is it still safe to login here?

Jim . . . '72 Super 1300, '70, 1750GTV, 2nd series,
'62, Lancia Flaminia Zagato3c, 2nd series
180OUT is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 12-19-2017, 02:40 PM
Registered User
 
AlfaEmitter's Avatar
 
Join Date: Aug 2009
Location: Minneapolis, MN
Posts: 109
I'm seeing the same indicator (null sign through the padlock icon, "Connection is Not Secure"). Is it safe?

Daniel Romero
'67 Duetto (white w/red)
'02 BMW 330 ci (silver w/black)
AlfaEmitter is offline  
post #3 of 5 (permalink) Old 12-23-2017, 01:24 PM
Registered User
 
divotandtralee's Avatar
 
Join Date: Nov 2005
Location: Cape Cod, MAssachusetts
Posts: 6,918
Box always asks if I want to open full content.... also never stay signed in even after asking to remember me
divotandtralee is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 12-23-2017, 06:50 PM
Registered User
 
Pat Braden's Avatar
 
Join Date: Aug 2006
Location: Dexter, Michigan USA
Posts: 4,631
Well, I can add it to the list of places I've been hacked or had my information compromised. I also get the lock with the red slash through it, but I also get that on one of my e-mail accounts and when I log-in to MyGateway at work. They just tell us not to worry about it.

I have so many protections and alerts set that I get a lot of e-mail notifying me of things that I initiated and are fine. I guess, that's better than not knowing. But it seems every time I turn around, I'm getting a new letter that one of my accounts has been compromised. Just off the top of my head: Yahoo e-mail, Blue Cross in California and Premera Blue Cross in Washington, Target, Experian, Bank of America and Union Bank resulted in fraudulent charges on my account ...

Cheryl
(Not an authority nor SME on anything, just PATSYF)
Pat Braden is offline  
post #5 of 5 (permalink) Old 07-29-2018, 10:03 AM
Registered User
 
Scrambles's Avatar
 
Join Date: Jul 2018
Location: North Carolina
Posts: 28
This is still an issue. Either not encrypting in transit or at rest or both or just not strong enough encryption. I had someone get my password/user name then login and change my user name and email (basically hijack my account) thankfully i had no tangible personal information on here. Given the amount of advertising on this site pretty sure a site upgrade should be sustainable. Who owns this site anyway?
Scrambles is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome