Alfa Romeo Bulletin Board & Forums

Alfa Romeo Bulletin Board & Forums (https://www.alfabb.com/bb/forums/)
-   Spider - 105 & 115 Series (1966-1994) (https://www.alfabb.com/bb/forums/spider-105-115-series-1966-1994/)
-   -   Strange Digital Clock happenings (https://www.alfabb.com/bb/forums/spider-105-115-series-1966-1994/683764-strange-digital-clock-happenings.html)

bejem17 07-27-2019 07:07 AM

Strange Digital Clock happenings
 
Hello All,
Last acquisition an 88 Black Alfa Veloce from California. Digital Clock keeps correct time when the car is running but definitely doesn't when the ignition is off. Logic suggests the clock would need a permanently "hot" power supply all the time but what I've got suggests that supply is not full time - Any thoughts gratefully received !
Obviously not super important !

ghnl 07-27-2019 07:10 AM

My guess (just a guess) is that the clock might have a small re-chargable battery. And that battery (if it has one) no longer holds a charge.

bejem17 07-27-2019 07:22 AM

Thanks for the idea , the clock is a 1988 original so it's unlikely to be a button battery and the size of the box is too small ,I think, to contain a AA or AAA size rechargeable, if I get to the stage of dismantling the clock I 'll certainly have a look,

SkiBum 07-27-2019 08:01 AM

7 Attachment(s)
I imagine your 88 and my 86 are similar, mine seems to work fine. Why not just run with the ball on your idea? I'm feel sure you are on the right track, but the question is, does it need two power sources? One switched and one not? If you only had a constant supply the clock would always be "on".....
Does Jim's schematics show the clock wiring? If you don't have one I can check it out, they are all laminated to my garage wall.

GV27 07-27-2019 08:17 AM

1 Attachment(s)
On an 88 the clock does get constant power and is in fact always on. It's LCD display draws very little power.

My guess is that somebody screwed with the wiring at some point and got it wrong.

Jim's diagram does show it, and his diagram is very easy to follow for figuring out just where the wires should run from/to. The service manual is clearer (for me, anyhow) on what gets powered when. I'm attaching it here - clock is on page 15.

Hit me up with a PM and I can send you Papajam's awesome color coded diagram.

Dbaliko 07-27-2019 08:44 AM

Quote:

Originally Posted by bejem17 (Post 8444824)
Hello All,
Last acquisition an 88 Black Alfa Veloce from California. Digital Clock keeps correct time when the car is running but definitely doesn't when the ignition is off. Logic suggests the clock would need a permanently "hot" power supply all the time but what I've got suggests that supply is not full time - Any thoughts gratefully received !
Obviously not super important !

I also had this issue . Check to make sure that the clock is connected to a fuse that’s always hot. If there was any work done by a PO to the fuse box it could be that the fuse was somehow wired incorrectly. Especially if you’re saying that the clock comes on when the car is running, but does not show the correct time. Does the clock say 12:00 every time that you start it?

Doug

GV27 07-27-2019 09:02 AM

Quote:

Originally Posted by GV27 (Post 8444862)
The service manual is clearer (for me, anyhow) on what gets powered when. I'm attaching it here - clock is on page 15.

Oh, my apologies. That's actually from the '90 service manual. I was thinking it was '88 since I have the file in the same folder as Jim's '88 color coded diagram (I don't think he made a '90 version). I think it should be the same in this area but not 100% sure.

edit: yeah it's the same connector so I do think it's the same between '88 and '90. Connector G84B.

bejem17 07-29-2019 06:58 AM

Thanks for everyone's input, I just noticed the cig lighter is permanently live, regardless of where the ignition key is so I could spur from that to the live on the clock to see if this confirms someone has screwed up the wiring.


All times are GMT -7. The time now is 02:28 PM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright 2002-2011 AlfaBB.com All Rights Reserved.

 
For the best viewing experience please update your browser to Google Chrome