Broken S1 upper front bumper bracket.... - Alfa Romeo Bulletin Board & Forums
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-19-2019, 04:42 PM Thread Starter
Senior Member
Gold Subscriber
 
Hodgepodge's Avatar
 
Join Date: Apr 2017
Location: Western Pennsylvania
Posts: 303
Garage
Broken S1 upper front bumper bracket....

OK, a common problem with S1 cars is when the front end is damaged, so is the square-tube upper bumper bracket. One of them on my red '66 is a tube insteade of square do I know it has been hit and repaired. My blue '69 has the original tubes, but one was very loosely attached and the weld snapped off as I was installing new bumers (see image, you can see th ebroken square tube behind the partially installed bumper). I looked but can't find any kind of replacement part avialable anywhere. Is that because everybody just fabricates something?

If you have had to rebuild your front upper bumper struts, what did you use?

https://www.alfabb.com/bb/forums/att...mentid=1577804

Thanks

Scott
Attached Images
 

Alfa-current: '66 Duetto, '69 Spider
Past: '74 Spider, '76 spider, '80 GTV 6
Other-Current: 11 BMWs, Ram 1500
Other-past: 16 BMWs, MGs, Triumphs, other stuff that doesn't count.
Hodgepodge is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome