Alfa Romeo Bulletin Board & Forums

Alfa Romeo Bulletin Board & Forums (https://www.alfabb.com/bb/forums/)
-   Spider - 105 & 115 Series (1966-1994) (https://www.alfabb.com/bb/forums/spider-105-115-series-1966-1994/)
-   -   S3 in tank fuel pump questions (https://www.alfabb.com/bb/forums/spider-105-115-series-1966-1994/682424-s3-tank-fuel-pump-questions.html)

pantera928 07-02-2019 06:39 PM

S3 in tank fuel pump questions
 
I have brought 2 S3 cars back to life and in the process, have had issues with new in tank pumps.
Tanks were boiled out and sealed and the sending unit, pump and sock strainer were replaced on both cars.
The new sending unit said something about not requiring the bracket to hold the pump onto the pick up tube. Just use the stepped hose and clamps. Well, over time, both pumps fell off using them that way. Not sure where I bought the senders. Likely Centerline or Vick.
I replaced one of the brackets and had to rig it a bit to use it with the new sender. That pump however locked up and now wont turn.

Questions are as follows.

Has anyone else been through this?

Has anyone found a way to keep the pump attached without the bracket?

What is the correct orientation of the sock strainer when placing the pump in the tank? I am wondering if it is getting squashed and not allowing the pump to pick up fuel properly thereby causing it to lock up..

Does anyone have the bracket that holds the pump onto the sender tube that will sell it? One of mine is too far gone.

Thanks
Greg

6alfas 07-02-2019 09:15 PM

2 Attachment(s)
Like this one? Sock sticks out a bit, not sure what yours looks like. I haven't tested the pump but the sender works good. Have a good clean tank as well, just harder to ship. $50 plus shipping for the sender and pump assembly. PM me if interested.

Chuck

pantera928 07-03-2019 06:51 AM

Chuck
That looks like it. Where are you located?

Greg

alfabeach 07-03-2019 08:46 AM

1 Attachment(s)
Same pump is used on old Volvo's

pantera928 07-03-2019 09:30 AM

Richard aka alfabeach

Good info. I figured it was a generic pump.

Thanks

Greg


All times are GMT -7. The time now is 12:56 AM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright 2002-2011 AlfaBB.com All Rights Reserved.

 
For the best viewing experience please update your browser to Google Chrome