I changed all exterior bulbs to LED - Page 4 - Alfa Romeo Bulletin Board & Forums
 18Likes
Reply
 
LinkBack Thread Tools Display Modes
post #46 of 62 (permalink) Old 04-05-2019, 10:34 AM
Registered User
 
Join Date: Jul 2016
Location: Bay Area, CA
Posts: 34
Garage
Hi -- the pin layout looks different for the EP26. My relay matches what centerline and vics sells for the S4 (pic attached). I was originally hoping for something to just plug in to keep the car mostly original looking, so I skipped the resistor path. There are also 1157 LED bulbs with built in resistors, but they are pricey and the ones available via Amazon are now labelled 'unavailable'. For now I just replaced the burnt old bulbs with new long-life standard lights.
Attached Images
 
kugu is offline  
Sponsored Links
Advertisement
 
post #47 of 62 (permalink) Old 04-05-2019, 01:20 PM
Registered User
 
spiderserie4's Avatar
 
Join Date: Jul 2011
Location: Cologne, Germany
Posts: 7,214
Quote:
Originally Posted by kugu View Post
Hi -- the pin layout looks different for the EP26
yes, I see now, you are absolutely correct, the original Lancia hazard/blinker relay has 2 prongs close to one another.

what about this one? looks correct...UK supplier
https://www.simtekuk.co.uk/product.p.../?k=:::1603589
Attached Images
 

Dom - Alfa Spider 1990 S4 - formerly: Alfa 101 Sprint, 2600 Sprint, Montreal - family classics: Jensen Interceptor II, '58 Hooper RR Silver Cloud I, Shadow II, '60 Corvette.
spiderserie4 is online now  
post #48 of 62 (permalink) Old 04-05-2019, 02:28 PM
Registered User
 
Join Date: Jul 2016
Location: Bay Area, CA
Posts: 34
Garage
That looks correct. The prong labeling looks decent as well. Thanks for finding this -- it was a different UK company than I had tried earlier.

It's cheap enough to just give it a whirl, but you can't order directly from outside the UK. You have to get a quote. I'll ask for a quote for 1 and see what they say :-).
kugu is offline  
Sponsored Links
Advertisement
 
post #49 of 62 (permalink) Old 04-06-2019, 11:50 AM
Registered User
 
Join Date: Jul 2016
Location: Bay Area, CA
Posts: 34
Garage
Just a follow up on the UK flasher relay for LED signals. The company responded and said Alfas weren't on their list of applications, but they agreed the pin placement looked correct. They asked for the pin labeling (input/output) on the unit itself. I sent what I could find online and on AlfaBB, and said they'd check it out and advise next week.
abeasley likes this.
kugu is offline  
post #50 of 62 (permalink) Old 04-10-2019, 03:52 PM
Registered User
 
abeasley's Avatar
 
Join Date: Mar 2019
Posts: 83
Garage
kugu,

Have you heard anything back about the UK Flasher relay? I'm interested to see if that will work.

Adam -- 1988 Alfa Romeo Spider Graduate
abeasley is offline  
post #51 of 62 (permalink) Old 04-10-2019, 04:15 PM
Registered User
 
Join Date: Jul 2016
Location: Bay Area, CA
Posts: 34
Garage
Nada. I will ping them again tomorrow if there is nothing in the morning.
kugu is offline  
post #52 of 62 (permalink) Old 04-10-2019, 06:28 PM
Registered User
 
howndog's Avatar
 
Join Date: Mar 2009
Location: E-town, Canada
Posts: 966
Quote:
Originally Posted by ossodiseppia View Post
Folks, resistors are not necessary for these LEDs to work on our vintage Alfas. These LEDs do not pull enough current to sufficiently heat the spring element in a thermal flasher. This resistor "fix" is meant for newer cars that experience hyper-flashing.

All you need do is swap the flasher unit for a modern one. This is less time consuming and cheaper. I bought the one in the picture below from Amazon for $10. It has a small adjustment screw (grey colored) which can be turned to control the rate of flashing. The only issue I have with this flasher is that it is silent. You can find a similar product that will emit a clicking sound much like a conventional thermal flasher.

Using the LEDs without resistors will reduce the amperage consumption and the wire harness will appreciate the break.

https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1
Will this flasher work on a 69 roundtail? I recently bought leds all around and the stop and rear signals work but the front signals don't flash...also what are the leds for the front parking lights? I ordered what I thought were correct but they too small.

1969 1750 Spider*Giorgia?*
1970 1750 Spider*magica*--mi ha lasciato per un altro,luglio 2015
howndog is offline  
post #53 of 62 (permalink) Old 04-11-2019, 11:19 PM
Registered User
 
Join Date: Oct 2013
Posts: 58
Quote:
Originally Posted by Dbaliko View Post
itís recommended to use the same color LED as the lens. That way you get a super bright light in the correct color.

Doug
Definitely agree with this, tried a white LED in stop/tail & it didn't look good, but a red LED looks both red & brighter.
Dbaliko likes this.
spidermale is offline  
post #54 of 62 (permalink) Old 04-19-2019, 08:26 PM
Registered User
 
Join Date: Oct 2015
Posts: 50
Quote:
Originally Posted by abeasley View Post
kugu,

Have you heard anything back about the UK Flasher relay? I'm interested to see if that will work.
Bump of curiosity.
4SFED4 is offline  
post #55 of 62 (permalink) Old 04-20-2019, 06:33 AM
Registered User
 
Join Date: Jul 2016
Location: Bay Area, CA
Posts: 34
Garage
Unfortunately, your humble correspondent hasn't discovered the secret handshake to get the relay's UK producer to ship me any. I contacted the company that spiderserie4 had found that produced a LED enabled relay that looks spot on for S3/S4 spiders. If it worked as advertised in would be a good deal too, as minus VAT, it would run about 16-17USD (before shipment cost).

But Simtek only ships direct from a web order within the UK. Outside of it, you have to request a purchase quote, which I did. I also asked it the relay was a replacement for the 4-pin units in later series Alfa Spiders -- and that's where things are hung up. They won't ship until they can verify it's a match (input/outputs). We're in a cycle where I ping them every 3-4 days, and they respond quickly apologizing and letting me know they'll get to it in 1-2 days. But the cycle continues. Probably a one-off order to the U.S. isn't ringing any sales bells (I did note to them if it works there would likely be other interested parties). I also offered to just take the risk and plug one in if they'd send it to me, and if the car burst into flames, that would be my problem -- but still no dice.

Anyway, at this point abeasley has offered to request purchase quote for a couple of units w/o mentioning the word 'alfa' (the relay was used by multiple euro car brands back in the day, but I don't know what brands Simtek considers 'tested'). The other option could be if there is any UK-living, Alfa-loving members reading this string and want to help, let me know. An internal UK order looks relatively simple.

So that a long response to a quick bump of curiosity. Now, it's out to de-weed the yard.

Regards,

Kurt
kugu is offline  
post #56 of 62 (permalink) Old 04-20-2019, 07:01 AM
Registered User
 
abeasley's Avatar
 
Join Date: Mar 2019
Posts: 83
Garage
I placed an order yesterday and hopefully it'll ship this coming week. I have an order confirmation but nothing else, I figured they were probably closed by then for the weekend.

Adam -- 1988 Alfa Romeo Spider Graduate
abeasley is offline  
post #57 of 62 (permalink) Old 04-23-2019, 04:44 PM
Registered User
 
abeasley's Avatar
 
Join Date: Mar 2019
Posts: 83
Garage
Unfortunately that supplier won't be able to get those flashers in... They sent me this email:


Unfortunately we have no stock of this part currently and our supplier has an open-ended lead time on them.

Therefore, with regret, we need to cancel and refund your order.

Sorry for any inconvenience caused.

Adam -- 1988 Alfa Romeo Spider Graduate
abeasley is offline  
post #58 of 62 (permalink) Old 04-23-2019, 07:30 PM
Registered User
 
Join Date: May 2005
Posts: 5,291
Well, that proves it was exactly the relay you need!



Robert
spiderserie4 and abeasley like this.
60sRacer is online now  
post #59 of 62 (permalink) Old 06-23-2019, 01:08 PM
Registered User
 
Join Date: Jul 2016
Location: Bay Area, CA
Posts: 34
Garage
LED flasher relay

Just wanted to follow-up on this thread from a couple of months ago. I wanted to convert the signal/brake lights on my S4 to LED without using resistors, etc., so I tried working with Simtek on the electronic flasher spiderserie4 had found, but this distributor proved to be useless (lots of promises, but zero follow through). Some google-sleuthing discovered the manufacturer for this relay was a company in Malta. I contacted them and their original response was that Alfa wasnít one of their supported brands, but since it listed this particular flasher relay as a substitute for the Lucas sfb163 which is frequently listed as a substitute for Spiders of that era, it might be worth a try. I tried to place an order, but then the mfg said the relay was a very poor seller and they didnít have anyÖÖ.

Making a long story short (and cutting out a rash of emails), they offered to build a few examples since they still had the parts, so I ordered 6 of them. There were special setup charges, and customs/shipping fees, but it still came out to be less than the standard S4 replacement relays online.

The units arrived and they worked as advertised (see attached pics). Tried it first with the regular incandescent bulbs still installed and it worked fine. Replaced everything with LEDs and still worked as promised. Nice bright directional and emergency lighting front and back. No resistors wired in.

Two things were a little different: 1) The signal cadence was quicker than the orig electo-mechanical version (but on par with the fully electronic signal cadence of the late model Mazda the Spider shares the garage with), and 2) zero clicking/signal sound since itís fully electronic. abeasley offered to be an experimenter and his experience seems to be the same.

If anyone is interested, I can supply the contact information. I also still have 3 examples of the relay that one can buy at cost ($30/ea delivered, or $20 if you leave near Los Gatos, CA and want to pick up). Iím selling at cost as I offer no warranty Ė although Iím not sure if the manufacturer offers one anyway on these units.

Regards,

Kurt
Attached Images
  
spiderserie4 and abeasley like this.
kugu is offline  
post #60 of 62 (permalink) Old 06-23-2019, 04:35 PM
Registered User
 
abeasley's Avatar
 
Join Date: Mar 2019
Posts: 83
Garage
Thanks again Kurt! It works great!

Adam -- 1988 Alfa Romeo Spider Graduate
abeasley is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome