New member - Alfa Romeo Bulletin Board & Forums
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 07-26-2018, 09:40 AM Thread Starter
Registered User
 
Join Date: Jul 2018
Posts: 76
New member

Hi. New member here. Just bought a 1987 Spider Veloce. Needs some work. Right now she bogs down and won't drive above 25mph. I'm thinking a clogged catalytic converter. I also read somewhere about the speedo causing a issue similar to this but I'm not 100% sure.
triz is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 07-26-2018, 10:35 AM
Registered User
 
nealric's Avatar
 
Join Date: Jun 2014
Location: Houston
Posts: 1,001
Garage
Quote:
Originally Posted by triz View Post
Hi. New member here. Just bought a 1987 Spider Veloce. Needs some work. Right now she bogs down and won't drive above 25mph. I'm thinking a clogged catalytic converter. I also read somewhere about the speedo causing a issue similar to this but I'm not 100% sure.
Given that the speedo is electronic (mechanical component is just the cable), I don't see how it would cause such a problem. The ECU doesn't see a speed input.

Clogged catalytic converter could be it, but could also be a fuel or spark issue. Couldn't hurt to swap the fuel filters (there's one under the car and one in the fuel tank) and spark plugs if the car hasn't run in a while.
nealric is offline  
post #3 of 6 (permalink) Old 07-26-2018, 02:37 PM
Registered User
 
Huzz's Avatar
 
Join Date: Dec 2010
Location: North East
Posts: 202
Garage
If it's a clogged cat, you can try to loosen the front pipe to create an exhaust leak and then
take it for a drive and see if it improves.
I would check the air flow meter and also the air hose to the plenum for cracks.
Fresh spark plugs and fresh gas could help.

You might have to do a fuel pressure and volume test.
Huzz is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 07-26-2018, 02:58 PM Thread Starter
Registered User
 
Join Date: Jul 2018
Posts: 76
Quote:
Originally Posted by Huzz View Post
If it's a clogged cat, you can try to loosen the front pipe to create an exhaust leak and then
take it for a drive and see if it improves.
I would check the air flow meter and also the air hose to the plenum for cracks.
Fresh spark plugs and fresh gas could help.

You might have to do a fuel pressure and volume test.
That is the plan, disconnecting the cat from the header. I did see some tape around the air intake. Plan on doing some real cleaning up of the engine bay. New valve cover gasket, plugs, wires and cleaning the throttle body for starters.
triz is offline  
post #5 of 6 (permalink) Old 07-26-2018, 04:01 PM
Senior Member
Gold Subscriber
 
radamm's Avatar
 
Join Date: Sep 2006
Location: Fisher, Illinois
Posts: 1,410
There is an easier test for a plugged exhaust system. Connect a vacuum gauge to the intake. A plugged system will cause the vacuum to drop drastically when the engine reaches the problem rpm.

__________
Rick

MEMBRO LATO OSCURO


69 850 Spider (A fond college days' memory)
81 Spider Veloce
Downstate Illinois SNO Director
radamm is online now  
post #6 of 6 (permalink) Old 07-26-2018, 05:30 PM
Registered User
 
Huzz's Avatar
 
Join Date: Dec 2010
Location: North East
Posts: 202
Garage
:thumbup1
Huzz is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome