79 2000 spider veloce - Page 2 - Alfa Romeo Bulletin Board & Forums
Reply
 
LinkBack Thread Tools Display Modes
post #16 of 20 (permalink) Old 03-12-2018, 05:53 AM
Senior Member
Gold Subscriber
 
bruce1976spider's Avatar
 
Join Date: Aug 2016
Location: Chardon, Ohio
Posts: 476
Garage
Yeah, BEFORE you go replacing all that stuff, try one of these on all four plugs: https://www.amazon.com/Lisle-20610-I...ter+automotive

You said it would fire on starter spray; that means it has to be sparking - and this cheap tester can tell you for sure without just blindly replacing things...

50 years from now - how are we going to restore a "classic" microprocessor based modern car?? Alfas - 1980 Spider, 1987 Milano, 1976 Spider
bruce1976spider is offline  
Sponsored Links
Advertisement
 
post #17 of 20 (permalink) Old 03-12-2018, 03:19 PM Thread Starter
Registered User
 
Nick Lysiak's Avatar
 
Join Date: Feb 2018
Location: Caldwell, ID, USA
Posts: 25
Garage
Quote:
Originally Posted by bruce1976spider View Post
Yeah, BEFORE you go replacing all that stuff, try one of these on all four plugs: https://www.amazon.com/Lisle-20610-I...ter+automotive

You said it would fire on starter spray; that means it has to be sparking - and this cheap tester can tell you for sure without just blindly replacing things...
No need, apparently I just needed to top up the battery. It started, but keeps flooding itself out. As soon as you touch the throttle it dies.

1979 Spider Veloce, 1978 Mercedes Benz 230 (Euro Spec) [Sold] 1960 Oldsmobile Dynamic 88 “scenicoupe” [Sold]
Nick Lysiak is offline  
post #18 of 20 (permalink) Old 03-12-2018, 03:25 PM Thread Starter
Registered User
 
Nick Lysiak's Avatar
 
Join Date: Feb 2018
Location: Caldwell, ID, USA
Posts: 25
Garage
Quote:
Originally Posted by Nick Lysiak View Post
Quote:
Originally Posted by bruce1976spider View Post
Yeah, BEFORE you go replacing all that stuff, try one of these on all four plugs: https://www.amazon.com/Lisle-20610-I...ter+automotive

You said it would fire on starter spray; that means it has to be sparking - and this cheap tester can tell you for sure without just blindly replacing things...
No need, apparently I just needed to top up the battery. It started, but keeps flooding itself out. As soon as you touch the throttle it dies.
Not really sure what I’ll do about that.

1979 Spider Veloce, 1978 Mercedes Benz 230 (Euro Spec) [Sold] 1960 Oldsmobile Dynamic 88 “scenicoupe” [Sold]
Nick Lysiak is offline  
Sponsored Links
Advertisement
 
post #19 of 20 (permalink) Old 03-12-2018, 06:07 PM
Registered User
Platinum Subscriber
 
Andrew's Avatar
 
Join Date: Mar 2004
Location: Berkeley, CA
Posts: 21,042
There are two threads going on this issue, one here, one in the engine section. Can I delete one or merge them?
Andrew
Andrew is online now  
post #20 of 20 (permalink) Old 03-12-2018, 06:15 PM Thread Starter
Registered User
 
Nick Lysiak's Avatar
 
Join Date: Feb 2018
Location: Caldwell, ID, USA
Posts: 25
Garage
Quote:
Originally Posted by Andrew View Post
There are two threads going on this issue, one here, one in the engine section. Can I delete one or merge them?
Andrew
do what you must. I made one thread and was told to make another elsewhere.

1979 Spider Veloce, 1978 Mercedes Benz 230 (Euro Spec) [Sold] 1960 Oldsmobile Dynamic 88 “scenicoupe” [Sold]
Nick Lysiak is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome