engine can't be revved up - Page 4 - Alfa Romeo Bulletin Board & Forums
 7Likes
Reply
 
LinkBack Thread Tools Display Modes
post #46 of 55 (permalink) Old 06-27-2017, 02:15 PM
Senior Member
Platinum Subscriber
 
alfaparticle's Avatar
 
Join Date: Oct 2004
Location: Columbia SC
Posts: 12,675
My experience with very low compression, much worse than yours, is that the car is hard to start but may run reasonably well at mid to high rpm.

Ed Prytherch
79 Spider
85 GTV6 3L
76 Suzuki GT500
2011 Jaguar XKR

A little government and a little luck are necessary in life, but only a fool trusts either of them. - P.J. O'Rourke
alfaparticle is online now  
Sponsored Links
Advertisement
 
post #47 of 55 (permalink) Old 06-27-2017, 06:51 PM Thread Starter
Registered Member
Gold Subscriber
 
mcola's Avatar
 
Join Date: Jun 2011
Location: Hamilton, Ontario, Canada
Posts: 1,903
Back at it tonight, first time in a while.
And as I mentioned earlier, frustrated to have not solved it by now, having checked and tried so many things.
In some cases, taking somebody else's word (no names) that something was checked and said to be ok, not realizing until after the discovery, that it was actually only checked during the breakdown of 1 month earlier

The lesson here folks, is assume nothing, and check everything making no assumptions.

So tonight I decide the check a few things I didn't personally check myself, and...... BINGO!!!
Attached Images
 
ghnl and CanHam86Spider like this.

Mike

'87 Quadrifoglio
mcola is offline  
post #48 of 55 (permalink) Old 06-27-2017, 06:57 PM Thread Starter
Registered Member
Gold Subscriber
 
mcola's Avatar
 
Join Date: Jun 2011
Location: Hamilton, Ontario, Canada
Posts: 1,903
Oh, forgot... back home to grab a used spare of each, and its alive!!!!!

Mike

'87 Quadrifoglio
mcola is offline  
Sponsored Links
Advertisement
 
post #49 of 55 (permalink) Old 06-27-2017, 07:08 PM
Senior Member
Gold Subscriber
 
Vintre's Avatar
 
Join Date: Nov 2006
Location: Waterdown, Ontario
Posts: 3,421
Quote:
Originally Posted by mcola View Post
Back at it tonight, first time in a while.
And as I mentioned earlier, frustrated to have not solved it by now, having checked and tried so many things.
In some cases, taking somebody else's word (no names) that something was checked and said to be ok, not realizing until after the discovery, that it was actually only checked during the breakdown of 1 month earlier

The lesson here folks, is assume nothing, and check everything making no assumptions.

So tonight I decide the check a few things I didn't personally check myself, and...... BINGO!!!
Wow!

Congrats Mike.

Now just to replace the head gasket and its all set.

Vin

1991 Spider Veloce - Red on Tan - Rosa Bionda
1987 Spider Quadrifoglio - Red on Grey - Rosa - Sold
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Honey, this is the last thing I have to do, then I'm finished. It'll just be a minute.
Vintre is online now  
post #50 of 55 (permalink) Old 06-27-2017, 07:12 PM
Senior Member
Platinum Subscriber
 
alfaparticle's Avatar
 
Join Date: Oct 2004
Location: Columbia SC
Posts: 12,675
Did that happen with a stock ignition?

Ed Prytherch
79 Spider
85 GTV6 3L
76 Suzuki GT500
2011 Jaguar XKR

A little government and a little luck are necessary in life, but only a fool trusts either of them. - P.J. O'Rourke
alfaparticle is online now  
post #51 of 55 (permalink) Old 06-27-2017, 08:32 PM Thread Starter
Registered Member
Gold Subscriber
 
mcola's Avatar
 
Join Date: Jun 2011
Location: Hamilton, Ontario, Canada
Posts: 1,903
Quote:
Originally Posted by alfaparticle View Post
Did that happen with a stock ignition?
Yes, and I meant to ask at the end of my earlier post... what would typically cause this to happen?

Mike

'87 Quadrifoglio
mcola is offline  
post #52 of 55 (permalink) Old 06-27-2017, 08:34 PM Thread Starter
Registered Member
Gold Subscriber
 
mcola's Avatar
 
Join Date: Jun 2011
Location: Hamilton, Ontario, Canada
Posts: 1,903
Quote:
Originally Posted by Vintre View Post
Wow!

Congrats Mike.

Now just to replace the head gasket and its all set.

Vin
Thanks. The head gasket is beyond anything I care to get involved in, although I'd like to drop in and have a look at things. For me, there is enough excitement troubleshooting and getting them running again.

Mike

'87 Quadrifoglio
mcola is offline  
post #53 of 55 (permalink) Old 06-27-2017, 09:38 PM
Registered User
 
Join Date: Mar 2015
Location: Hamilton, Ontario
Posts: 21
Thanks again Dr.Mike and all those contributing to this thread!! Now I can drive her to the cottage for a well needed restoration, body work, paint and engine rebuild! Can't wait! Here's another pic of the rotor. I swear I checked the rotor out three weeks before the issue and it looked in good condition, similar to the replacement rotor. Would love to know how it can fail so bad so fast!?

Imgur: The most awesome images on the Internet
CanHam86Spider is offline  
post #54 of 55 (permalink) Old 06-27-2017, 11:55 PM
Registered User
 
spiderserie4's Avatar
 
Join Date: Jul 2011
Location: Cologne, Germany
Posts: 7,067
Quote:
Originally Posted by CanHam86Spider View Post
Would love to know how it can fail so bad so fast!?

Imgur: The most awesome images on the Internet
cheap import part, I'm guessing.
Only a matched Bosch cap and rotor will get anywhere near my car....too many poorly manufactured parts out there.
John533i likes this.

Dom - Alfa Spider 1990 S4 - formerly: Alfa 101 Sprint, 2600 Sprint, Montreal - family classics: Jensen Interceptor II, '58 Hooper RR Silver Cloud I, Shadow II, '60 Corvette.
spiderserie4 is offline  
post #55 of 55 (permalink) Old 06-28-2017, 11:55 AM
Registered User
 
John533i's Avatar
 
Join Date: Mar 2014
Location: Oregon
Posts: 1,291
British car guys have been dealing with this for a while, and has lead to one vendor making a MINT (probably) off selling quality caps and rotors. Get matching Bosch from now on! Write down the PN's for cap and rotor, then just order on Amazon. Our S3 cap n rotors are common to many vehicles, so they are cheap cheap cheap, and off-brand are more expensive in many cases.

My 90 525i distributor cap is over $100, for comparison!!!

86 spider Veloce
74 TR6
John533i is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome