Tach. problem - Alfa Romeo Bulletin Board & Forums
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-16-2006, 12:04 PM Thread Starter
Registered User
 
Join Date: Mar 2006
Location: Elburn,Il
Posts: 204
Tach. problem

When I bought my '85 spider the tach didn't.work. I recently repalced it with a known good tach from my other car. Simple I thought, just unplug the 2 connectors above the fuse panel and plug in the other tach and make sure it wokks in this one before making the total switch. Staet the engine, tach works, rev engine, needlde goes up, do it again, still good. Take out the old tach., fish out old wires and plugs. Fish new tach wires in, plug in connectors, bolt all back together, start engine, tach doesn't. work. check connections twice, not even a quiver of the needle when the key is turned on (like it did when tested). Any suggestions? I have one more thac but am afraid to try it out. Any way to test wiring? Thanks - Conrad

'85 Spider Grad. driver '85 Spider Veloce - rescue
'91 164L green - parts '93 164L red - daily driver (good weather) '91 164S
Knick is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome