Has any one had a problem with the snap ring in a drive shaft support? - Alfa Romeo Bulletin Board & Forums
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-12-2009, 04:10 PM Thread Starter
Registered User
 
Join Date: Apr 2009
Posts: 21
Has any one had a problem with the snap ring in a drive shaft support?

I just got a new drive shaft support from IAP and the channel that holds the snap ring is very shallow compared to the one that came off the car, in other words the snap ring rides high in the channel compared to the old one where the snap ring in half way down in the grove? any suggestions?....87 spider
thanks
chewys spider is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-12-2009, 04:54 PM
Registered User
 
Join Date: May 2005
Posts: 116
Does it have any retention properties? You can also green locktight it as well. That should hold iot, ask iap if by chance there is a machining fault. Good luck
otteud is offline  
post #3 of 5 (permalink) Old 05-13-2009, 09:12 AM
Registered User
 
Join Date: Feb 2008
Location: Novato Cal
Posts: 409
Hi Did you buy the snap ring from IAP too? Jim

Now....93 164s, 91 164s, 91 164L, 79 spider, '31 Ford model A Rat Rod, 88 Milano 3.0, 87 testarossa, 05 SL600 twin turbo V-12, 82 GTV6-3.0, Dodge Ram
alfaman1963 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 05-13-2009, 11:00 AM Thread Starter
Registered User
 
Join Date: Apr 2009
Posts: 21
no they did not have one in stock but said the factory one would work but it didn't so i went down to my local Caterpillar dealer......every body has one of those in town right? well they found one that worked great! the part number for any one that is interested is 6L-8797
thanks for all you help
Kurt
chewys spider is offline  
post #5 of 5 (permalink) Old 05-13-2009, 11:30 AM
Registered User
 
Join Date: Feb 2008
Location: Novato Cal
Posts: 409
ring

Thanks for the info... I asked you that because the IAP ring never worked for me ..... Thanks Jim

Now....93 164s, 91 164s, 91 164L, 79 spider, '31 Ford model A Rat Rod, 88 Milano 3.0, 87 testarossa, 05 SL600 twin turbo V-12, 82 GTV6-3.0, Dodge Ram
alfaman1963 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome