Alfa No Spark - Alfa Romeo Bulletin Board & Forums
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-02-2019, 12:42 AM Thread Starter
Registered User
 
hoguspuss's Avatar
 
Join Date: Sep 2015
Location: Auckland New Zealand
Posts: 20
Garage
Alfa No Spark

Hi

Super not running. No spark at any plugs. Tested fuse box with circuit tester. Power to 5 right hand fuses (lights and all the bits which don't affect the internal combustion side of things). Nothing to remaining (ignition etc).

I am a bit lost when it comes to the dark art of auto electrics. Any suggested causes or things I should check would be welcomed. Keen to hit the road again.

thanks in advance.
hoguspuss is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-02-2019, 01:24 AM
Registered User
 
Join Date: Apr 2019
Posts: 19
wiring diag

I'm terrible at diagnosing electrics, but it you haven't seen it, Andrew posted the Super wiring diagram here:

https://www.alfabb.com/bb/forums/sed...agram-pdf.html
71super is offline  
post #3 of 5 (permalink) Old 05-02-2019, 05:59 AM
Registered User
Platinum Subscriber
 
Andrew's Avatar
 
Join Date: Mar 2004
Location: Berkeley, CA
Posts: 21,051
You have power on the + side of the coil with the key on? If not it won't run. Another test, hook a test light up to the - side of the coil, crank engine. Light go on and off? If not, won't run.
Andrew
Andrew is online now  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 06-07-2019, 07:49 PM Thread Starter
Registered User
 
hoguspuss's Avatar
 
Join Date: Sep 2015
Location: Auckland New Zealand
Posts: 20
Garage
Thanks for your input, turned out to be multiple issues starting with poor fuse connection, dodgy distributor and a couple of knackered leads. Just about to install 123 distributor and new leads so hopefully all will be sorted
hoguspuss is offline  
post #5 of 5 (permalink) Old 06-08-2019, 07:34 AM
Senior Member
Platinum Subscriber
 
Alfa69GTV1750's Avatar
 
Join Date: Jul 2013
Location: San Diego, CA
Posts: 628
Quote:
Originally Posted by hoguspuss View Post
Thanks for your input, turned out to be multiple issues starting with poor fuse connection, dodgy distributor and a couple of knackered leads. Just about to install 123 distributor and new leads so hopefully all will be sorted
I have a wiring diagram for a US '66 Super if you'd like it.

Contact me by email if you'd like me to send it (email is: my handle @ gmail)

Mike
1969 GTV 1750
1966 Super
San Diego, CA

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Alfa69GTV1750 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale: 1939 Alfa Romeo 8C 2900 B Touring Berlinetta bello105 Alfa Romeo Cars For Sale & Wanted 18 02-10-2019 11:57 AM
Volkswagen wants Alfa Romeo, but Fiat doesn't want to sell Alfisto Steve Alfa Romeo Topics Not Covered Elsewhere 265 10-02-2012 03:41 PM
Geneva Preview: Alfa Romeo 8C Spider Production Version smestas Alfa Romeo Topics Not Covered Elsewhere 0 02-21-2008 10:40 PM
I know it's been asked a million times Nipper Milano/75 (1985-1993) 27 08-24-2007 06:23 AM
Alfa Le Mans entries 1936-1939 dretceterini Alfa Romeo History 1 04-13-2007 11:01 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome