Alfa Romeo Bulletin Board & Forums - Search Results
Advanced Search
Showing results 1 to 16 of 16
Search took 0.01 seconds.
Search: Posts Made By: samtheagent
Forum: Spider - 105 & 115 Series (1966-1994)   06-22-2019, 11:21 AM
Replies: 2
Views: 126
Posted By samtheagent
Thank you, this will be a great help! I still...

Thank you, this will be a great help! I still need to figure out where it's broken from and how to repair it.
Forum: Spider - 105 & 115 Series (1966-1994)   06-22-2019, 10:26 AM
Replies: 2
Views: 126
Posted By samtheagent
1983 Spider Veloce top frame

Anyone have a diagram or an outline of the attachment points on the convertible top? My b-pillars are detached and it looks like they are broken off but I can't tell where the attachment points are....
Forum: Spider - 105 & 115 Series (1966-1994)   06-19-2019, 03:47 PM
Replies: 10
Views: 304
Posted By samtheagent
Mine is dead,wont open at all

Mine is dead,wont open at all
Forum: Spider - 105 & 115 Series (1966-1994)   06-19-2019, 03:43 PM
Replies: 10
Views: 304
Posted By samtheagent
Thank you, very nice of you to offer

Thank you, very nice of you to offer
Forum: Spider - 105 & 115 Series (1966-1994)   06-19-2019, 08:34 AM
Replies: 10
Views: 304
Posted By samtheagent
Auxiliary air valve

In need of a new Auxiliary air valve, after doing a bunch of research I've come to the conclusion that there is none out there, any sources on these? Where is there anything else that could be made...
Forum: Spider - 105 & 115 Series (1966-1994)   06-15-2019, 06:11 AM
Replies: 13
Views: 363
Posted By samtheagent
The problem was in the fuse box, bad contact on...

The problem was in the fuse box, bad contact on the fuse panel. Thank you all for your help. I now have the tachometer, fuel gauge, charging light corrected. Car is running after replacing all the...
Forum: Spider - 105 & 115 Series (1966-1994)   06-14-2019, 06:55 AM
Replies: 4
Views: 196
Posted By samtheagent
Forum: Spider - 105 & 115 Series (1966-1994)   06-14-2019, 06:04 AM
Replies: 4
Views: 196
Posted By samtheagent
Cool 1983 Spider Veloce wiring diagram

Can anyone point me in the right direction? My charging light is on but alternator is working. I have several other electrical issues that I need to figure out, but it would be nice to know what's...
Forum: Engine Management   06-14-2019, 05:15 AM
Replies: 62
Views: 3,164
Posted By samtheagent
If you look on YouTube you can see videos that...

If you look on YouTube you can see videos that take them apart and show you the inside of multiple filters. Fram is definitely Junk! Here is a link to the, https://m.youtube.com/watch?v=iTNJLEV8CG8
Forum: Spider - 105 & 115 Series (1966-1994)   06-13-2019, 12:46 PM
Replies: 13
Views: 363
Posted By samtheagent
Thank you :)

Thank you :)
Forum: Spider - 105 & 115 Series (1966-1994)   06-13-2019, 10:27 AM
Replies: 13
Views: 363
Posted By samtheagent
I paid $500 for the car. But it definitely needs...

I paid $500 for the car. But it definitely needs work.
Forum: Spider - 105 & 115 Series (1966-1994)   06-13-2019, 10:09 AM
Replies: 13
Views: 363
Posted By samtheagent
I'm missing the arm on the turn signa switch. I...

I'm missing the arm on the turn signa switch. I just bought the car, it wasn't running but I replaced the fuel lines, repaired the vacuum leaks and now it runs great except when it's cold. I took it...
Forum: Spider - 105 & 115 Series (1966-1994)   06-13-2019, 09:56 AM
Replies: 13
Views: 363
Posted By samtheagent
System is charging at 13.8 volts green wire good...

System is charging at 13.8 volts green wire good at both ends.
Forum: Spider - 105 & 115 Series (1966-1994)   06-13-2019, 07:53 AM
Replies: 13
Views: 363
Posted By samtheagent
The light is on full bright, thank you for the...

The light is on full bright, thank you for the help!
Forum: Spider - 105 & 115 Series (1966-1994)   06-13-2019, 06:05 AM
Replies: 13
Views: 363
Posted By samtheagent
first time posting

Good morning, sorry if I'm posting in the wrong place I'd like to apologize in advance. I own a 1983 Alfa Romeo veloce Spider. My alternator lite is on but according to the parts store the alternator...
Forum: Guests, New Members & Introductions - Please Read   06-13-2019, 05:00 AM
Replies: 1
Views: 76
Posted By samtheagent
Thank you

Greetings from Austin Texas, thank you for letting me join the group. I just purchased a 1983 Alfa Romeo Spider veloce. Looking forward to working on her and bringing her back to life. Please don't...
Showing results 1 to 16 of 16

 
Forum Jump
 
For the best viewing experience please update your browser to Google Chrome