Alfa Romeo Bulletin Board & Forums - Search Results
Advanced Search
Showing results 1 to 9 of 9
Search took 0.00 seconds.
Search: Posts Made By: Salsa903
Forum: Electrical, Chassis & Lighting   05-12-2019, 05:36 PM
Replies: 9
  1991 S4
Views: 259
Posted By Salsa903
Switched the lamp assemblies and the issue went...

Switched the lamp assemblies and the issue went to the other side.

I reversed the wires on the socket of the lower outside tail lamp assembly and everything worked!!

Got it!

Thanks everyone...
Forum: Electrical, Chassis & Lighting   05-12-2019, 08:42 AM
Replies: 9
  1991 S4
Views: 259
Posted By Salsa903
Thanks Spiderseries4. I cleaned those...

Thanks Spiderseries4.

I cleaned those grounds.

I wonder if I reversed the splices on the new sockets it would matter?

Will check the voltage and fuses again.

Thanks again for your...
Forum: Electrical, Chassis & Lighting   05-11-2019, 07:22 PM
Replies: 9
  1991 S4
Views: 259
Posted By Salsa903
I cleaned the grounds on left rear quarter panel,...

I cleaned the grounds on left rear quarter panel, the ground on battery, grounds on both headlamps, cleaned and tightened grounds on tail light assemblies and grounds on passenger rear side of the...
Forum: Electrical, Chassis & Lighting   04-22-2019, 04:48 PM
Replies: 9
  1991 S4
Views: 259
Posted By Salsa903
I checked the fuses. I will check grounds. ...

I checked the fuses. I will check grounds. Thanks
Forum: Electrical, Chassis & Lighting   04-17-2019, 07:14 PM
Replies: 9
  1991 S4
Views: 259
Posted By Salsa903
1991 S4 - Left Tail lights

I have a very strange problem or problems with my 91 S4.

Lights off left and right blinker work fine.
Lights on left blinker works and right blinker does not work
Lights on left tail lights do...
Forum: Spider - 105 & 115 Series (1966-1994)   04-15-2019, 06:52 PM
Replies: 35
Views: 7,890
Posted By Salsa903
Got a heat gun on it and went right on! Thanks...

Got a heat gun on it and went right on! Thanks all for your input.
Forum: Spider - 105 & 115 Series (1966-1994)   04-11-2019, 08:54 PM
Replies: 35
Views: 7,890
Posted By Salsa903
Thanks Pantera928! After working on this again...

Thanks Pantera928! After working on this again this evening I am wondering if I should take the AC compressor off? I finally got the hose over the lip of the water pump, but cant get it on enough...
Forum: Spider - 105 & 115 Series (1966-1994)   04-11-2019, 06:38 AM
Replies: 35
Views: 7,890
Posted By Salsa903
Wow those hoses look nice! Thanks for the...

Wow those hoses look nice! Thanks for the suggestion. I failed to mention I have a 1991 Spider with AC and it looks like they do not have a hose for that.
Forum: Spider - 105 & 115 Series (1966-1994)   04-10-2019, 07:57 PM
Replies: 35
Views: 7,890
Posted By Salsa903
I am experiencing the same issue trying to get a...

I am experiencing the same issue trying to get a new hose on the water pump. Any new suggestions?

Thanks
Showing results 1 to 9 of 9

 
Forum Jump
 
For the best viewing experience please update your browser to Google Chrome