Classic Alfa -- Now worst web site ever!!! - Page 2 - Alfa Romeo Bulletin Board & Forums
Reply
 
LinkBack Thread Tools Display Modes
post #16 of 43 (permalink) Old 08-26-2019, 10:54 AM
Senior Member
Platinum Subscriber
 
alfaparticle's Avatar
 
Join Date: Oct 2004
Location: Columbia SC
Posts: 12,980
Looks OK on Firefox/WIN7

Ed Prytherch
79 Spider
76 Suzuki GT500
2011 Jaguar XKR

A little government and a little luck are necessary in life, but only a fool trusts either of them. - P.J. O'Rourke
alfaparticle is offline  
Sponsored Links
Advertisement
 
post #17 of 43 (permalink) Old 08-26-2019, 10:55 AM
Registered User
 
GV27's Avatar
 
Join Date: Dec 2004
Location: Lakewood, Colorado
Posts: 1,755
Garage
Send a message via AIM to GV27
Android
Attached Images
 

Chris

1990 Spider Veloce
GV27 is online now  
post #18 of 43 (permalink) Old 08-26-2019, 11:02 AM
Registered User
 
GV27's Avatar
 
Join Date: Dec 2004
Location: Lakewood, Colorado
Posts: 1,755
Garage
Send a message via AIM to GV27
Quote:
Originally Posted by tubut View Post
The JSON file (data in JavaScript Object Notation) may be critical for the page layout (the PNG image file for sure isn't). Maybe those who get a decent page layout have this file cached on their system.
No, that's not it. I've posted enough screenshots but I just tried it from a VM I spun up yesterday afternoon that has definitely not been to their site before. It looks/works just fine on there as well.

Chris

1990 Spider Veloce
GV27 is online now  
Sponsored Links
Advertisement
 
post #19 of 43 (permalink) Old 08-26-2019, 11:51 AM Thread Starter
Registered User
 
tubut's Avatar
 
Join Date: Sep 2003
Location: Vancouver, BC
Posts: 9,209
Garage
Quote:
Originally Posted by GV27 View Post
No, that's not it. I've posted enough screenshots but I just tried it from a VM I spun up yesterday afternoon that has definitely not been to their site before. It looks/works just fine on there as well.
Great info, thank you. Could you do me a favor and please check in your browser console if the JSON file loads on your VM and/or how long it takes to load? I have a suspicion there may be a regional timeout or availability issue of this file (the PNG gets loaded from an edge network, but the JSON supposedly comes from their own server).

In my browser console, I get 4 hard errors (one of them a "Uncaught TypeError" in jquery-3.4.1.min.js, another a syntax error in manifest, possibly triggered by custom.js that comes from an edge network).

Name:  Screenshot 2019-08-26 11.48.54 (cropped).jpg
Views: 65
Size:  83.3 KB

The file custom.js seems to be at least partially responsible for page navigation:

Code:
$(function() {

	$('.navPages-action.has-subMenu').click(function() {
		$(this).siblings('.navPage-subMenu').toggleClass('is-open');
		$(this).toggleClass('is-open');
	});

	// Quantity selectors
	$('.page-content, #quickSearch').on('click', '.form-increment-custom button', function(e) {

		var _ = $(this);
		var input = _.siblings('input');
		var val = parseInt(input.val());

		if(_.data('action') === 'dec' && val > 1) {

			val--;

		} else if(_.data('action') === 'inc') {

			val++;

		}

		input.val(val);

		// console.log(val);

	});

	// FAQ ACCORDION

	$('[data-accordion]').on('click', 'li', function() {
		
		$(this).siblings('li').find('div').slideUp(300);

  		$(this).find('div').slideToggle(300);

  		$(this).siblings('li').find('svg').removeClass('rotated');
  		$(this).find('svg').toggleClass('rotated');

  	});

  	$('#sidebar-scroll-trigger').click(function() {

		var sidebar = $('.page-sidebar');
		sidebar.scrollTop(sidebar.scrollTop() + 100);

	});

  	$('img.lazyload').load(function() {
	    console.log($(this).attr('src') + ' loaded');
	});

});

-Ruedi
[SIZE="1"]'63 2600 Touring Spider (AR 191437, the car that started the 2000/2600 International Register, reassembly in progress)
ex-'65 2600 SZ (AR 856043, the car in my avatar, sold as resto project to Austria)
Maintainer of a private 2600 SZ register (not the one in the Netherlands).[/SIZE]

Last edited by tubut; 08-26-2019 at 11:59 AM.
tubut is offline  
post #20 of 43 (permalink) Old 08-26-2019, 12:05 PM
Registered User
 
Kristianjaeger's Avatar
 
Join Date: Jan 2019
Posts: 34
Works fine for me using the Chrome browser. Just a suggestion, contact them directly instead of posting here to try to resolve before going to a public forum, no pun intended. Cheers. I've ordered from them several times with no issues and they have good customer service as well.

'72 GTV 2000 project car
Kristianjaeger is offline  
post #21 of 43 (permalink) Old 08-26-2019, 12:12 PM
But Mad North-Northwest
Platinum Subscriber
 
Gubi's Avatar
 
Join Date: Sep 2003
Location: SF Bay Area, CA
Posts: 9,822
Itís something on your system, Ruedi. Works fine for me on multiple devices, and much more usable than their old site.

Tom

1963 Giulia Spider (1750 engine)
1974 GTV
1991 Spider
Former: 1987 Milano Gold
Gubi is online now  
post #22 of 43 (permalink) Old 08-26-2019, 12:39 PM
Registered User
 
GV27's Avatar
 
Join Date: Dec 2004
Location: Lakewood, Colorado
Posts: 1,755
Garage
Send a message via AIM to GV27
Quote:
Originally Posted by tubut View Post
Great info, thank you. Could you do me a favor and please check in your browser console if the JSON file loads on your VM and/or how long it takes to load? I have a suspicion there may be a regional timeout or availability issue of this file (the PNG gets loaded from an edge network, but the JSON supposedly comes from their own server).
Screenshot attached.

Geoscreenshot.com is a good site for testing a web page from different vantage points. Right now it's showing it load correctly from Bengaluru (India), Singapore and Santa Clara (California). There is a Vancouver option but you have to sign up to get it.

https://www.geoscreenshot.com/capture
Attached Images
 

Chris

1990 Spider Veloce

Last edited by GV27; 08-26-2019 at 12:47 PM.
GV27 is online now  
post #23 of 43 (permalink) Old 08-26-2019, 01:11 PM Thread Starter
Registered User
 
tubut's Avatar
 
Join Date: Sep 2003
Location: Vancouver, BC
Posts: 9,209
Garage
Quote:
Originally Posted by GV27 View Post
Screenshot attached.

Geoscreenshot.com is a good site for testing a web page from different vantage points. Right now it's showing it load correctly from Bengaluru (India), Singapore and Santa Clara (California). There is a Vancouver option but you have to sign up to get it.

https://www.geoscreenshot.com/capture
Super, thank you -- this is a great tool! The screenshot below (using servers in Toronto and Vancouver) shows the issue is a regional (geographic), technical content delivery problem.

Let's hope it's temporary, but one way or the other: The root of end user problems like this is still poor website design.

Name:  Screenshot 2019-08-26 13.08.43 (cropped).jpg
Views: 69
Size:  36.9 KB

-Ruedi
[SIZE="1"]'63 2600 Touring Spider (AR 191437, the car that started the 2000/2600 International Register, reassembly in progress)
ex-'65 2600 SZ (AR 856043, the car in my avatar, sold as resto project to Austria)
Maintainer of a private 2600 SZ register (not the one in the Netherlands).[/SIZE]

Last edited by tubut; 08-26-2019 at 01:31 PM.
tubut is offline  
post #24 of 43 (permalink) Old 08-26-2019, 07:55 PM
Registered User
 
genericwood's Avatar
 
Join Date: Jul 2003
Posts: 2,789
I just order on my phone using Safari. Great service from Classic!

Erik
'66 GTV racecar, '71 Spider racecar, '74 GTV street car, '71 GTV project
genericwood is offline  
post #25 of 43 (permalink) Old 08-26-2019, 09:17 PM
Registered User
 
Join Date: Aug 2019
Location: Sacramento, CA
Posts: 6
I was on here yesterday looking to price parts and functionally worked fine for me. Also kind of liked the design but that may just be me.
jasonh444 is offline  
post #26 of 43 (permalink) Old 08-26-2019, 10:18 PM
Registered User
 
Join Date: Dec 2010
Location: Adelaide (Modbury)
Posts: 730
Quote:
Originally Posted by tubut View Post
I don't know if any of you have seen the new Classic Alfa web site. I think it's the worst web site ever -- unusable in Chrome and Firefox on desktop and Android!!! Good on them for making it hard to place an order.

The bottom of the says "Website designed by BA Creative" -- the crappy Classic Alfa web site makes it clear that this is a design company to stay away from.
Maybe they 'Classic Alfa' don't understand how people search for car parts and or the BA Creative company does not understand either.
Steve105 is offline  
post #27 of 43 (permalink) Old 08-26-2019, 10:53 PM Thread Starter
Registered User
 
tubut's Avatar
 
Join Date: Sep 2003
Location: Vancouver, BC
Posts: 9,209
Garage
Quote:
Originally Posted by Steve105 View Post
Maybe they 'Classic Alfa' don't understand how people search for car parts and or the BA Creative company does not understand either.
Partially correct. The core issue is that their home page not working for everybody everywhere across the globe all the time. It's a flaw in how the web site delivers content. Classic Alfa got bamboozled by BA Creative. They didn't even care to forward traffic from the old domain classicalfa.co.uk to the new domain classicalfa.com. As a result, Classic Alfa will lose business not because of the services they provide, but because of the services they were provided.

-Ruedi
[SIZE="1"]'63 2600 Touring Spider (AR 191437, the car that started the 2000/2600 International Register, reassembly in progress)
ex-'65 2600 SZ (AR 856043, the car in my avatar, sold as resto project to Austria)
Maintainer of a private 2600 SZ register (not the one in the Netherlands).[/SIZE]
tubut is offline  
post #28 of 43 (permalink) Old 08-26-2019, 10:56 PM Thread Starter
Registered User
 
tubut's Avatar
 
Join Date: Sep 2003
Location: Vancouver, BC
Posts: 9,209
Garage
Quote:
Originally Posted by jasonh444 View Post
I was on here yesterday looking to price parts and functionally worked fine for me. Also kind of liked the design but that may just be me.
If you scroll back through the thread, you'll learn that it works in some regions but not in others (like mine).

-Ruedi
[SIZE="1"]'63 2600 Touring Spider (AR 191437, the car that started the 2000/2600 International Register, reassembly in progress)
ex-'65 2600 SZ (AR 856043, the car in my avatar, sold as resto project to Austria)
Maintainer of a private 2600 SZ register (not the one in the Netherlands).[/SIZE]
tubut is offline  
post #29 of 43 (permalink) Old 08-27-2019, 03:07 AM
Registered User
 
IRONBLOCK's Avatar
 
Join Date: Feb 2008
Location: Georgia
Posts: 3,664
Garage
Ruedi,

The Classic Alfa site works too well for me! Yet another batch of Duetto restoration parts on their way. Just think of how much money you must be saving...

Mark
IRONBLOCK is offline  
post #30 of 43 (permalink) Old 08-27-2019, 04:53 AM
Registered User
 
alfa2go's Avatar
 
Join Date: Feb 2005
Location: Brisbane, Australia
Posts: 2,670
Works perfectly for me on safari, chrome and Firefox. I dream/browse it a few times a week and it hasn’t glitched for me.

66' Giulia Super, '67 GT Veloce, '72 Montreal

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
www.montreal.alfa-male.com
alfa2go is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome