Alfa Romeo Bulletin Board & Forums - Reply to Topic
Thread: Stabilizer bar Strut Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
05-31-2019 06:12 PM
richardbradford
Quote:
Originally Posted by sharvey View Post
I followed the advice from the board and replaced the sway bar struts and bushings, I finally had the time to take it out for a test drive and had a shimmy in the steering wheel (left to right back and forth).

Let me add that this is after I had the clutch replaced.

I took the front tires to my brothers shop to have the tires balanced, top of the line Hunter machine, wheels were true and didn't take a lot of weight. Re-installed, torqued properly, took for a test drive and still have shimmy that starts at 50 mph and will gradually increase with speed.
I double checked tightness of axels, tie rods etc. Any suggestions on where to go next is greatly appreciated.
If it increases with speed that suggests a rotational issue rather than a suspension one. In other words, everything in the drivetrain is a suspect. If it changes according to gear, then focus on the gearbox/engine. If it doesn't change according to gear then focus on the driveshafts/wheels.
05-27-2019 04:31 PM
Alfisto Steve Sounds like you are not running hub centric wheels with 5x98 Alfa 5x98mm bolt pattern. What wheels are you using?
05-27-2019 02:22 PM
sharvey
Hats off to Del & Cris

Taking Del and Cris's advice, I un-rotated my tires, ie put them back the way they were and the steering wheel is as smooth as silk. I inspected the wheels that I took off the front that were causing the shimmy and it looks like the holes for the bolts might be slightly wider than the front, I don't have a working micrometer but will get one and check.
Lesson learned - always go back to the simplest solution first!

Thanks as always guys.
05-25-2019 10:54 PM
jc96 been my experience that if my wheels are not centered exactly on the hub(s), I get similar results to you. Now, I have aftermarket wheels and centering rings so take this in consideration. ciao, chris
05-25-2019 01:25 PM
Del Usually a front tire imbalance problem, with those described symptoms (out of balance forces approaching and driving the fundamental frequency of a front suspension spring/mass/damper mechanism, which is around 60-70 mph for most cars), but maybe a tire out of round, or having broken cords from pothole impact? Had that once, ended up with a bulge on the inner side of one tire.

Change the fronts to the rear and see if the symptoms change or go away.

Through the years, I've found that Alfa steering feel is pretty darn sensitive to front tire balance, having sometimes to go back for a redo, making the operator tighten up the machine readings. Sometimes "good enough" is not good enough in such direct steering.

One reason I think I would not like electric steering, as when the Alfa steering wheel is tremor free because of fine wheel balance, etc, it has great feedback, as compared to most of the new electric systems with their relative numbness, so I've read.
05-25-2019 01:06 PM
sharvey
Front end diagnostic help

I followed the advice from the board and replaced the sway bar struts and bushings, I finally had the time to take it out for a test drive and had a shimmy in the steering wheel (left to right back and forth).

Let me add that this is after I had the clutch replaced.

I took the front tires to my brothers shop to have the tires balanced, top of the line Hunter machine, wheels were true and didn't take a lot of weight. Re-installed, torqued properly, took for a test drive and still have shimmy that starts at 50 mph and will gradually increase with speed.
I double checked tightness of axels, tie rods etc. Any suggestions on where to go next is greatly appreciated.
04-15-2019 12:41 PM
Del "The shop manual confirms you need to split that ball joint in order to remove and replace the bar itself"

Actually, not quite true, as I replaced the front bar in my LS with an aftermarket version without separating the ball joints. Yes, not easy, but it can be done. I think the manual just figured that separating the joints would be the fastest method, with the proper tools.

I believe that the idea from him was that he wants to buy the new links from wherever asap, and install them soonest while being able to drive the car carefully for whatever essentials. Will be an easy job, doing both at the same time.
04-15-2019 12:20 PM
Michael Smith Looking at the photo again I see an additional hazard. The bar will work when that wheel rises but not when it falls giving you different handling in a right turn (fairly normal) but reduced understeer in a left turn. I would repair that asap if it were my car.

I haven't looked to see if the two nuts you need to remove and replace can be reached without removing the steering tie rod from the ball joint. The shop manual confirms you need to split that ball joint in order to remove and replace the bar itself. For the drop link (Alfa calls it a strut link) you do not need to remove the bar, only the link itself.

If you can reach the nut on the end of the bar you could effect a temporary if somewhat noisy repair by removing the nut, fitting a suitably sized washer (larger than the eye) to the end of the bar where it protrudes through the eye of the drop link and replace the nut, pulling the end of the bar and the tattered remains of the bushing back into the eye to give you most of the bar's resistance in both left and right turns. Replacing the drop link itself only takes a few minutes longer though so were it my car I'd buy new links and install them. I'd guess the right hand end link is probably just as deteriorated as the left end in the photo. Generally it is wise to repair suspension bits in pairs, left and right sides together to ensure symmetrical performance in left and right turns. Like tires, steering and brakes you don't want to rely on badly worn parts for your personal safety.
04-15-2019 08:44 AM
Del Yes, I need to buy a pair of those for my LS. I like them, installed easily on my 91S. I'll get to you soon.
04-15-2019 08:20 AM
Alfissimo Int.

https://alfissimo.com/suspension-fro...w-bushing.html

This is what I offer. I don't like the other style at all. Too prone to failure and very quickly.

Yours in pic is done. Replace it.
04-14-2019 08:18 PM
Del Good advice. I've done just this, and that's why I recommended driving sanely at moderate speeds. City streets are little problem, not any worse than driving something like my bro's old Austin Healey 3000 in the rain, lol. That was somewhat tricky, as you could spin out pulling out of a parking lot if the street was wet.
04-14-2019 05:50 PM
Michael Smith Be aware that a disconnected front bar will reduce understeer maybe to the point of inducing oversteer, especially on throttle lift. Exercise care when driving so as not to drive close to handling limits. The effect can be quite disconcerting. Adding air pressure to the rear tires would be a wise safety move. Standard tire pressures are 3 psi lower for the rear so adding those 3 psi to the rear tires only will help stabilize the handling a fair bit.
04-14-2019 04:36 PM
Alfisto Steve I find the easiest way to install the sway bar lollipop links is to jack up front of car so both wheels off the ground to take load off both sides of sway bar.

Usually the lollipop end pops off sway bar because the washer under the nut has too small of outside diameter. I put larger OD washer under item 7 nut shown in link below.

Also lower bushings on either side of lower suspension Arm go bad, too.

See this link of my pix of these links and washers: https://www.alfabb.com/bb/forums/5507585-post20.html
04-14-2019 12:55 PM
richardbradford Unlikely to get it back on and will just come off again if you do. If you have to drive the car, drive gently. Personally would also remove the damaged part to avoid it hitting the sway/anti roll bar from underneath.
04-14-2019 10:18 AM
Del I replaced the links on my 91S without doing any of that. Bought the good ones from Jason (Alfissimo). Did both at the same time. Had no problem. Need to do the LS next.

Yes, just remove them and drive sanely at moderate speeds.
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome