Alfa Romeo Bulletin Board & Forums - Reply to Topic
Thread: fuel hose length Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
05-11-2015 06:25 PM
pezthing Ic. Thanks.
05-11-2015 06:12 PM
RedVerde I don't know the answer to this but if you are still in need of an answer I would suggest posting the question in the Spider section or one of the Technical forum sections. (Maybe one of the moderators can move this thread there for you) I don't think this AROSC section gets much traffic which is probably why you have not gotten any responses.
04-29-2015 12:05 AM
pezthing
fuel hose length

Have some issues with a fuel leak were the fuel hose enters the filter from the pump. I figured the filter needs changed since who knows how long that has been done. I ordered one and should get it in a few days. I was thinking maybe I should replace the hose while I'm at it. Went on international auto parts and they sell by the foot. Pump to filter looks to be less than a foot. Can someone tell me how many feet of hose I need from the filter to the engine. And what millimeter hose do I need. I think it's 8mm but I want to make sure before I order. Thanks. New to this so I have a 1988 alfa romeo graduate spider. Thanks

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome