Alfa Romeo Bulletin Board & Forums - Reply to Topic
Thread: S3 in tank fuel pump questions Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
07-03-2019 09:30 AM
pantera928 Richard aka alfabeach

Good info. I figured it was a generic pump.

Thanks

Greg
07-03-2019 08:46 AM
alfabeach Same pump is used on old Volvo's
07-03-2019 06:51 AM
pantera928 Chuck
That looks like it. Where are you located?

Greg
07-02-2019 09:15 PM
6alfas Like this one? Sock sticks out a bit, not sure what yours looks like. I haven't tested the pump but the sender works good. Have a good clean tank as well, just harder to ship. $50 plus shipping for the sender and pump assembly. PM me if interested.

Chuck
07-02-2019 06:39 PM
pantera928
S3 in tank fuel pump questions

I have brought 2 S3 cars back to life and in the process, have had issues with new in tank pumps.
Tanks were boiled out and sealed and the sending unit, pump and sock strainer were replaced on both cars.
The new sending unit said something about not requiring the bracket to hold the pump onto the pick up tube. Just use the stepped hose and clamps. Well, over time, both pumps fell off using them that way. Not sure where I bought the senders. Likely Centerline or Vick.
I replaced one of the brackets and had to rig it a bit to use it with the new sender. That pump however locked up and now wont turn.

Questions are as follows.

Has anyone else been through this?

Has anyone found a way to keep the pump attached without the bracket?

What is the correct orientation of the sock strainer when placing the pump in the tank? I am wondering if it is getting squashed and not allowing the pump to pick up fuel properly thereby causing it to lock up..

Does anyone have the bracket that holds the pump onto the sender tube that will sell it? One of mine is too far gone.

Thanks
Greg

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome