Alfa Romeo Bulletin Board & Forums - Reply to Topic
Thread: LED Tail Light Replacement Bulb Reply to Thread
Title:
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Alfa Romeo Bulletin Board & Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
06-01-2018 01:59 PM
Alfajay
Quote:
Originally Posted by bruce1976spider View Post
just plug the CF13 JL-02 in and swap in an LED for a indicator bulb. And it works even if you still use non-LED turn signal bulbs.
Right. When you retain the mechanical flasher, it can be tricky to arrive at the right resistor value to put in parallel with the LED's to achieve the proper current. Too much/little and the flash rate is too high/low (or is it too low/high?).
06-01-2018 01:40 PM
bruce1976spider
Quote:
Originally Posted by Alfajay View Post
... So you can just plug a small LED into the bulb holder, and that's it. No need for a current-limiting resistor, as in most LED circuits? I guess the current limiting is in the flasher.
Exactly right. The operating current seen on the "E" connection of the CF13 JL-02 during a flash goes up to about 10 mA, enough to light an LED. But not enough to light an incandescent bulb.

What I liked is that I really don't need to make any permanent alterations, just plug the CF13 JL-02 in and swap in an LED for a indicator bulb. And it works even if you still use non-LED turn signal bulbs.
06-01-2018 01:23 PM
Alfajay
Quote:
Originally Posted by bruce1976spider View Post
Below is my indicator rig: I used a cut bit of a plastic tie wrap as a center divider, and trimmed the LED legs. That's the whole process!
OK, thanks for the quick reply on mixing LED and incandescent bulbs.

So you can just plug a small LED into the bulb holder, and that's it. No need for a current-limiting resistor, as in most LED circuits? I guess the current limiting is in the flasher.

---------------------

I would like to have brighter brake lights on my Duetto, but am less concerned with brighter tail and turn signal lights (I seldom drive the Duetto after dark and no one pays attention to turn signals here anyways).

Since the Duetto groups the brake and tail lights on a dual-filament, 1157 bulb, while the turn signal is by itself on a single-filament 1156, a short cut would be to just swap the 1157's for LED bulbs. That way, you don't get into adding resistors in parallel with the LED exterior bulbs, or substituting an LED for the indicator bulb.
06-01-2018 01:14 PM
Kantarjiev
Quote:
Originally Posted by bruce1976spider View Post
Do you have one of papajamma's circuit schematics for your Spider?
I do! But to say that my wiring harness has been modified would be putting it mildly. I currently have a two-pin flasher, for starters. So I will have to spend some time figuring out how the current setup is meant to work, or how to put things back to the original way. It appears that one terminal is hot (red) and the other has three wires (at least) of differing colors.

How does that dash indicator come out? From the front or the back? I've never pulled one of the little jeweled indicators, and have several that need work...
06-01-2018 11:54 AM
bruce1976spider
Quote:
Originally Posted by Alfajay View Post
What happens if you retain the conventional, incandescent bulb in the dash indicator with the CF13 JL-2 flasher? It doesn't light?

Also, will the CF13 JL-2 flasher support a mix of LED bulbs at the rear and incandescents at the front (or vice versa)? Or are you saying that all bulbs (including the indicator) need to be LED?
1) Correct - you won't see a blink from the dash, but the flasher will work. It's pretty easy to substitute an LED for the incandescent indicator bulb though. You might get it wrong (+ to -) but no harm, just reverse it. BTW the unit won't flash if the indicator LED is backwards!!

2) The CF13 JL-02 works from 0.02 Amps up to 20 Amps, so a mix of LED's and incandescent lamps is fine.

Below is my indicator rig: I used a cut bit of a plastic tie wrap as a center divider, and trimmed the LED legs. That's the whole process!
06-01-2018 11:47 AM
Alfajay
Quote:
Originally Posted by bruce1976spider View Post
...the flasher draws so little current on "E" that you must use an LED, oriented correctly (+) side to the flasher, (-) to the dash indicator, in place of an incandescent lamp.
I used a 10mA green LED in my indicator lamp holder, and it lights nicely.
What happens if you retain the conventional, incandescent bulb in the dash indicator with the CF13 JL-2 flasher? It doesn't light?

Also, will the CF13 JL-2 flasher support a mix of LED bulbs at the rear and incandescents at the front (or vice versa)? Or are you saying that all bulbs (including the indicator) need to be LED?
06-01-2018 06:56 AM
bruce1976spider Do you have one of papajamma's circuit schematics for your Spider?

On it, for my 1976 Spider the 3-pin flasher is marked as "C" going to the turn signal switch & e-flasher switch (which sources a "flashing" 12 VDC for the lamps), "R" goes to the indicator on the dash, and "+" to a fused 12VDC.

The cheap CF13 JL-2 flasher for LED loads I used connects with it's "B" terminal where "+" is, "L" on the flasher goes to the "C" connection wire, and (this is the tricky part!!) the flasher's "E" connection goes to the "R" wire... but the flasher draws so little current on "E" that you must use an LED, oriented correctly (+) side to the flasher, (-) to the dash indicator, in place of an incandescent lamp.

I used a 10mA green LED in my indicator lamp holder, and it lights nicely.
05-31-2018 03:26 PM
Kantarjiev I just went down the path of LUYED turn signals in my '72. I love the light output, but my can flasher wouldn't flash them. So I bought one of the orange AUDEW flashers and ... it won't flash them. They are always on.

Now, some previous owner had rigged the car to use a two-prong flasher instead of three. I haven't completely traced that down yet, but there's a bundle of wires at the output of the flasher, so I have a guess at how it's working (the dash indicator gets lit up when there's draw from either side of the turn signals). I don't know if the dash indicator is LED or incandescent. I'm contemplating going back to a 3-prong unit ... but I'm also wondering if adjusting the flash rate screw on the AUDEW might help.

Thoughts/words of wisdom?

Thanks.
09-05-2017 11:14 AM
bruce1976spider
Quote:
Originally Posted by flandrian View Post
... Turn signal flashes too quickly so I have ordered two resistors to fix that. ...
Oh, the irony of adding resistors to make the turn signals draw enough current to make the old flasher behave properly Much more light from LED's with less power... I prefer the solution of changing out the flasher can for a new LED-rated module. Make sure those resistors are where they can safely dump some heat.

Love the way the new LED lamps look!
09-05-2017 10:15 AM
ossodiseppia Those LEDs look great.
09-05-2017 09:50 AM
flandrian
Roundtail LED upgrade

Just the info I needed to help upgrade my roundtail. I attempted to do this years ago but LED bulbs available at the time were dimmer than stock. I ordered bulbs Friday. Crazy amazon delivered them free SUNDAY am. After a few glitches (broken ground wire in housing, re-broken lens mounts) I got things ironed out. Painted the interior of the sample housing white. Turn signal flashes too quickly so I have ordered two resistors to fix that. Here are links I used on amazon. Some of those links from earlier upgrades in this thread no longer exist.

Resistors:
https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1

turn signals:
https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1

Brake lights:
https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1
04-13-2017 08:58 AM
tadslc
Quote:
Originally Posted by ossodiseppia View Post
The multi -pin flasher you mentioned is used only for the emergency flashers, not the turn signals. Please look under the dash of your S1 on the left side of the steering column. You should see a canister with two wires (1 red and 1 black), attached to it. That is the turn signal flasher.
Thanks, I'll have a look.
04-13-2017 07:01 AM
Sfizio I hate when that happens! Hey Nick, also check that you did not accidentally blow a fuse. I did when I was changing out bulbs for LEDs.
04-13-2017 06:59 AM
ossodiseppia
Quote:
Originally Posted by ntvnyer View Post
Osso and everyone,

I just did these bulbs on my '74 .
I replaced my old flasher switch the same day and now the flashers do not work.
if I recall correctly my blinker relay has more wires than what is shown on the orange part, am i looking at the wrong part or do I need to combine some of the connections?

thanks
If you are using a conventional bi-metalic flasher relay, it will not work with LED bulbs. The bi-metalic flasher relay needs heat to trip the flasher switch. The heat is caused by the current draw of the light bulbs. LED bulbs do not pull the current filament bulbs pull, so the bi-metalic flasher relay will not work.

Quote:
Originally Posted by tadslc View Post
I have a Series 1 and Series 2 and both use 4-5 pin relays. As per normal practice, they work both the turn signals and emergency flashers. The S2 one was originally a 5 pin but I got a 4 pin to work since the original is not available anymore.
The multi -pin flasher you mentioned is used only for the emergency flashers, not the turn signals. Please look under the dash of your S1 on the left side of the steering column. You should see a canister with two wires (1 red and 1 black), attached to it. That is the turn signal flasher.
04-13-2017 06:02 AM
ntvnyer I did brake/tail lights and the reverse lights. I avoided the blinkers because of the flasher issues. My grounds are good, I cleaned them up while I had the taillight assemblies out. I think my problem will turn out to be disturbed wiring under the dash. I am lucky in that the wiring on my car is not chopped up, but that also means that I am dealing wil brittle old stuff. I will post a solution when I find one.
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome